Bug 468435 - Rawhide kernel breaks RTL8111/8168B NIC
Rawhide kernel breaks RTL8111/8168B NIC
Status: CLOSED DUPLICATE of bug 468360
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 14:25 EDT by Chris
Modified: 2008-10-24 18:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 18:19:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (1.76 KB, text/plain)
2008-10-24 14:25 EDT, Chris
no flags Details
/var/log/messages with broken 2.6.27.3-39.fc10.i686 (37.53 KB, text/plain)
2008-10-24 14:32 EDT, Chris
no flags Details
/var/log/messages with working 2.6.27.3-30.rc1.fc10.i686 (38.77 KB, text/plain)
2008-10-24 14:34 EDT, Chris
no flags Details

  None (edit)
Description Chris 2008-10-24 14:25:45 EDT
Created attachment 321443 [details]
lspci output

Description of problem:
Installing the latest rawhide kernel disabled my RTL8111/8168B NIC. LEDs go out as soon as the kernel gets loaded. Booting an older kernel again doesn't help.

Version-Release number of selected component (if applicable):
kernel-2.6.27.3-39.fc10.i686

How reproducible:
once

Steps to Reproduce:
1. Upgrade from kernel-2.6.27.3-30.rc1.fc10.i686 to kernel-2.6.27.3-39.fc10.i686
2. reboot
  
Actual results:
dead NIC

Expected results:
working NIC as in the kernels before

Additional info:
The Problem seems to be the (buggy?) r8169 driver from realtek [1] which is unable to activate the r8168 properly. Loading the original module from [2] didn't work for me although there are quite a lot of success reports out there.

[1] http://peanuts.earth.sinica.edu.tw/blog/?p=47
[2] http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2
Comment 1 Chris 2008-10-24 14:32:19 EDT
Created attachment 321444 [details]
/var/log/messages with broken 2.6.27.3-39.fc10.i686
Comment 2 Chris 2008-10-24 14:34:13 EDT
Created attachment 321445 [details]
/var/log/messages with working 2.6.27.3-30.rc1.fc10.i686
Comment 3 Yanko Kaneti 2008-10-24 14:47:16 EDT
dup 468360
Comment 4 Dave Jones 2008-10-24 18:19:16 EDT

*** This bug has been marked as a duplicate of bug 468360 ***

Note You need to log in before you can comment on or make changes to this bug.