Bug 468461 - [PATCH] grub timeout=0 means serial users cannot select kernel or add kernel args
[PATCH] grub timeout=0 means serial users cannot select kernel or add kernel ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: booty (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-24 16:22 EDT by Doug Chapman
Modified: 2013-01-09 23:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-18 17:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (762 bytes, patch)
2008-11-04 13:34 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-10-24 16:22:44 EDT
Description of problem:
A recent change to booty made the default timeout value in grub.conf 0.  On my system with serial console I no longer am able to select the kernel to boot.   I imagine we would have the same issue on a VGA console (will test that when I have a system with a VGA console handy).

This would be seen as very un-user friendly if a user needs to select a different kernel or add kernel options in order to boot.

Version-Release number of selected component (if applicable):
booty-0.105-1.fc10.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2008-10-28 13:16:56 EDT
For the VGA console, you can hold a key (like Shift or Control) at boot to bring up the GRUB menu. This is the expected behavior.

Does that work for serial console as well?
Comment 2 Doug Chapman 2008-10-28 17:35:03 EDT
(In reply to comment #1)
> For the VGA console, you can hold a key (like Shift or Control) at boot to
> bring up the GRUB menu. This is the expected behavior.
> 
> Does that work for serial console as well?

No, this doesn't appear to work for me on serial console.
Comment 3 Will Woods 2008-10-28 18:06:27 EDT
Yeah, now that I think about it, holding Shift wouldn't do anything over a serial link. 

Can you try hitting a key (any key - spacebar will do nicely) when GRUB loads and see if it gives you the expected menu?
Comment 4 Jeremy Katz 2008-10-28 18:12:39 EDT
Alternately, I guess if we set up serial, we can change the timeout
Comment 5 Doug Chapman 2008-10-29 08:25:28 EDT
I have tried holding keys and hitting them very rapidly as the menu comes up.  As Jeremy suggests we need to increase the timeout (I would suggest 5 sec) on serial console.
Comment 6 Bill Nottingham 2008-11-04 13:04:56 EST
What does your grub.conf look like?

It appears that we set:

timeout=0
terminal --timeout=5 serial console

Is the first overriding the second?
Comment 7 Doug Chapman 2008-11-04 13:21:51 EST
(In reply to comment #6)
> What does your grub.conf look like?
> 
> It appears that we set:
> 
> timeout=0
> terminal --timeout=5 serial console
> 
> Is the first overriding the second?


yes, this is what my config looks like.  The 2 timeouts are for different things (as I understand it).  The "terminal --timeout=5" is the time it waits for a user to press a key on either the serial or the VGA console, this is what allows grub to automatically detect which console the user is using.  

The timeout=0 is the time it waits for the user to select a kernel before it boots, that's the one causing the problem here.
Comment 8 Bill Nottingham 2008-11-04 13:34:04 EST
Created attachment 322465 [details]
patch

Here's a booty patch that theoretically should fix this - I don't have any serial-console capable machines to test with right now.
Comment 9 Mads Kiilerich 2008-11-11 05:37:50 EST
As discussed in Bug 468526 the timeout value isn't used if any chainloader entries exists. It is overruled by chaintimeout which apparently defaults to 5 but is configurable. Depending on how 468526 is resolved I think the patch from comment 8 should set chaintimeout too.
Comment 10 Bill Nottingham 2008-11-18 17:00:27 EST
Should be fixed in booty-0.106-1.fc10, grub-0.97-38.fc10.
Comment 11 Jesse Keating 2008-11-18 17:47:18 EST
Tagged for final.

Note You need to log in before you can comment on or make changes to this bug.