Bug 468471 - system-config-network: traceback at startup
system-config-network: traceback at startup
Status: CLOSED DUPLICATE of bug 468355
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-24 18:03 EDT by Will Woods
Modified: 2008-10-24 23:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 23:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full traceback / dump (2.36 KB, text/plain)
2008-10-24 18:03 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-10-24 18:03:17 EDT
Created attachment 321470 [details]
full traceback / dump

system-config-network crashes at startup on my system. It seems to be having trouble talking to HAL?

Component: system-config-network
Version: 1.5.10
Summary: TB24531662 NCBackendHal.py:103:getDevices:TypeError: not enough arguments for format string

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 275, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 300, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 312, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 759, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 603, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 483, in updateFromSystem
    self.updateFromHal(hdellist)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 448, in updateFromHal
    cards = hal.probeCards()
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 124, in probeCards
    card = self.getDevices(udi)
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 103, in getDevices
    hw.Description = "%s %s" % self.getVendor(udi)
TypeError: not enough arguments for format string
Comment 1 Matthias Clasen 2008-10-24 23:35:56 EDT

*** This bug has been marked as a duplicate of bug 468355 ***

Note You need to log in before you can comment on or make changes to this bug.