Bug 468481 - Alienarena can't find game.so
Alienarena can't find game.so
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alienarena (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 20:20 EDT by Doncho N. Gunchev
Modified: 2008-10-30 08:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 08:51:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2008-10-24 20:20:45 EDT
Description of problem:
Both alienarena and alienarena-server can't find game.so. 

Version-Release number of selected component (if applicable):
alienarena and alienarena-server 7.20-1.fc9

How reproducible:
always

Steps to Reproduce:
1. yum -y install alienarena\*
2. alienarena-server
3. alienarena
  
Actual results:
------- Loading game.so -------
LoadLibrary (game.so): cannot open shared object file: No such file or directory
********************
ERROR: failed to load game DLL
********************
Error: Error during initialization

Expected results:
Working game :-)

Additional info:
I worked around the problem with:
export LD_LIBRARY_PATH='/usr/lib64/alienarena/arena'
Comment 1 Tom "spot" Callaway 2008-10-25 12:46:58 EDT
Hmm, I'm not able to reproduce the error here (on x86_64 rawhide).

I have a suspicion though, so I've kicked off a new build. I'll put a comment up when the new build is done, please update to that package and try again.
Comment 2 Tom "spot" Callaway 2008-10-25 13:03:25 EDT
Try these packages:

http://koji.fedoraproject.org/koji/buildinfo?buildID=67513
Comment 3 Doncho N. Gunchev 2008-10-26 16:34:37 EDT
I tried with alienarena-7.20-2.fc9.x86_64 but still the same problem (starting /usr/bin/alienarena and /usr/bin/alienarena-wrapper from console (konsole) or the GUI menu under KDE 4 at least, didn't try under Gnome). The game stops with 'Awaiting connection...' and the message is

...
======== CRX Initialized ========

------- Loading game.so -------
********************
ERROR: failed to load game DLL
********************
Master server at 69.143.100.63:27900
Sending shutdown to 69.143.100.63:27900
...

I have to enter the menu (`) and type quit there. Removing ~/.codered did not make any difference. This is Fedora 9 with updates-testing enabled.

strace shows:
...
write(3, "------- Loading game.so -------\n", 32) = 32
open("/home/mr700/.codered/arena/game.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("./arena/game.so", O_RDONLY)       = -1 ENOENT (No such file or directory)
open("/home/mr700/.codered/data1/game.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("./data1/game.so", O_RDONLY)       = -1 ENOENT (No such file or directory)
write(3, "********************\nERROR: fail"..., 73) = 73
open("/etc/resolv.conf", O_RDONLY)      = 15
...

And if I 'ln -s /usr/lib64/alienarena/arena/game.so /home/mr700/.codered/arena/game.so' it works.
Comment 4 Tom "spot" Callaway 2008-10-26 17:10:15 EDT
Okay, well, this should definitely fix it:

http://koji.fedoraproject.org/koji/taskinfo?taskID=904845

Please let me know if it does.
Comment 5 Doncho N. Gunchev 2008-10-26 18:11:45 EDT
No, did not work, sorry...

I'd love to know what's the problem. I see the new '/usr/bin/alienarena' does 'export LD_***', but it does nothing this time (read: with alienarena-7.20-3.fc9.x86_64 and 7.20-2), I even tried exporting it prior to running the game - no difference. This time only symlinking helps.

With alienarena-7.20-1.fc9.x86_64 if I do exactly the same export by hand it works. My fault I didn't check if 'the export trick' is still working with 7.20-2, just strace and symlink.

Next thing I tried was 7.10 (to see I'm not going nuts) and there's a slight difference (note the newly created user for the test) - the library is printed with it's full path:

--- cut ---
[mr701@ws-dgunchev ~]$ strace alienarena 2>&1 | grep 'game.so'
open("/usr/lib64/alienarena/game.so", O_RDONLY) = 9
------- Loading /usr/lib64/alienarena/game.so -------
LoadLibrary (/usr/lib64/alienarena/game.so)
[mr701@ws-dgunchev ~]$ _
--- cut ---

I'll ask a college to verify my observations.
Comment 6 Tom "spot" Callaway 2008-10-26 23:26:54 EDT
Hmm... I really wish I could reproduce this, I'm just trying things sequentially.

http://koji.fedoraproject.org/koji/taskinfo?taskID=905346

In -2, I took out a patch that I thought might be to blame. Since LD_LIBRARY_PATH stopped working at the same time, I've re-enabled that patch for -4, and left the LD_LIBRARY_PATH export in the start scripts. Give this a try and see if it works. 

Thanks for your patience.
Comment 7 Doncho N. Gunchev 2008-10-28 17:49:59 EDT
It works, thanks!

OT: shouldn't the script be !/bin/bash if 'export A=B' (insdead of 'A=B; export A) is being used?
Comment 8 Tom "spot" Callaway 2008-10-29 10:25:38 EDT
Yep. I'll commit that and push the final update.
Comment 9 Fedora Update System 2008-10-29 11:36:28 EDT
alienarena-7.20-5.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/alienarena-7.20-5.fc8
Comment 10 Fedora Update System 2008-10-29 11:36:30 EDT
alienarena-7.20-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/alienarena-7.20-5.fc9
Comment 11 Fedora Update System 2008-10-30 08:51:10 EDT
alienarena-7.20-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-10-30 08:55:08 EDT
alienarena-7.20-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.