Bug 468497 - kernel does not builds with 92.1.13.el5 kernel patch
kernel does not builds with 92.1.13.el5 kernel patch
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 05:52 EDT by Peter
Modified: 2008-10-25 08:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 08:44:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.config (46.35 KB, text/plain)
2008-10-25 05:52 EDT, Peter
no flags Details

  None (edit)
Description Peter 2008-10-25 05:52:42 EDT
Created attachment 321498 [details]
.config

Description of problem:

If I have e1000 modules enabled in kernel and e1000e disabled, kernel fails to build with the following error:

  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o: In function `e1000_init_module':
e1000_main.c:(.init.text+0x47e2): undefined reference to `e1000e_driver_request'
make: *** [.tmp_vmlinux1] Error 1

Seems that the following code cause this(drivers/net/e1000/e1000_main.c):
static int __init
e1000_init_module(void)
{
        int ret;
        extern int e1000e_driver_request();

        e1000e_driver_request();

        printk(KERN_INFO "%s - version %s\n",
               e1000_driver_string, e1000_driver_version);

In vanilla kernel there is no calls to e1000e driver functions while here they are. Possible solution is to enabled e1000e when e1000 is enabled.

Note, I'm using the following openvz kernel:
http://wiki.openvz.org/Download/kernel/rhel5/028stab059.3
which is based on rhel5 patchset and since vanilla openvz patch does not have e1000e driver I think this bug is caused by rhel patchset. Sorry if I'm wrong.

Just in case that's required I've attached .config file which does not allow me to build kernel.
Comment 1 Jiri Pirko 2008-10-25 08:44:11 EDT
Following 3 lines:
>         extern int e1000e_driver_request();
> 
>         e1000e_driver_request();
are not (and never was) in our code so it looks like they are a part of openvz patchset after all. Please look again. Closing this issue. Feel free to open it again.

Note You need to log in before you can comment on or make changes to this bug.