Bug 468563 - wireless iwl4965 kernel>=2.6.26 drops data
wireless iwl4965 kernel>=2.6.26 drops data
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 21:33 EDT by John Floyd
Modified: 2009-07-14 10:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Floyd 2008-10-25 21:33:53 EDT
Description of problem:

Using a ethernet wireless bridge, connects from laptop ok in adhoc mode. Pinging the other end of the link just stops gettting responses after a while. Reset the link, using ifdown/up at the laptop starts everthing working again.

Version-Release number of selected component (if applicable):

Works with kernel 2.6.25-14, fails on the all official 2.6.26's.  Laptop is kept up to date on updates.


How reproducible:

Using ipup connect to ethernet wireless bridge.  All looks ok thru iwconfig.
Ping the device attached to the bridge, OK.  After a short period of time (10-15 pings) the ping returns stop (though pinging continues).  Same result from the device attached to the bridge (pinging back to the fedora laptop).  

Happens every boot session under 2.6.26 kernels.

Actual results:

Looks like a data loss not a connection loss,.  Iwconfig still reports connection to bridge.  Laptop still sending pings but no returns.

Expected results:

Ping returns.


Additional info:

Taking the interface down then up again with ipdown/up restarts the links with initial succesful pings.  But returns stop after 10-15 pings.
Comment 1 John Floyd 2008-10-26 23:03:41 EDT
Also fails on the recent released kernel-2.6.26.6
Comment 2 John Floyd 2008-10-27 16:49:54 EDT
The problem appears to definitely be at the laptop (iwl4965) end!

If I setup the wireless link as before between the laptop and the ethernet wireless bridge (attached to a desktop) and ping from the desktop through the bridge to the laptop (Running in adhoc mode to the bridge) I get the following.

Running tcpdump on the laptop (through iwl4965) when the ping responses stop on the desktop, the laptop tcpdump shows that they are still arriving and that reply is being sent but are not being received!!  

Again this is only occurring on fedora kernels > 2.6.26.x.  I have not tried any vanilla kernels.

Cheers
Comment 3 Bug Zapper 2009-06-09 23:05:03 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-07-14 10:23:45 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.