Bug 468571 - Browsing to a certain website causes hard lockup
Browsing to a certain website causes hard lockup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 01:12 EDT by Garry Reisky
Modified: 2008-11-21 00:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 00:55:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broken image (191.51 KB, image/png)
2008-10-26 02:17 EDT, Yanko Kaneti
no flags Details
Xorg.0.log to go with the previous image (33.60 KB, text/plain)
2008-10-26 02:22 EDT, Yanko Kaneti
no flags Details
Xorg log (68.20 KB, text/plain)
2008-10-26 02:40 EDT, Garry Reisky
no flags Details

  None (edit)
Description Garry Reisky 2008-10-26 01:12:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Load firefox
2. Browse to www.corneliamarie.com
3. System lockups. I tried to ssh in and I can't. Hard lock
  
Actual results:


Expected results:


Additional info:
Comment 1 Garry Reisky 2008-10-26 01:58:00 EDT
This hard lock can also be triggered by going into KDE's System Settings and clicking on 'Appearance' or 'Desktop' Changing the color scheme in Desktop will hard lock.
Comment 2 Yanko Kaneti 2008-10-26 02:13:05 EDT
Perhaps you could attach your /var/log/Xorg.0.conf and tell us what kernel, X
and driver version are you running.

# uname -r

# rpm -q xorg-x11-drv-ati xorg-x11-server-Xorg


Here on my X1550 with 512MB, this particular background image ->
http://www.corneliamarie.com/images/new_bkgd_r3_c1.jpg 
makes firefox have a blocky colour seizure but the kernel does not crash.
[attachment follows]

$ lspci -nn | grep Radeon
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV505 CE [Radeon
X1550 64-bit] [1002:715f]
$ uname -r
2.6.27.4-47.rc3.fc10.i686
$ rpm -q xorg-x11-drv-ati xorg-x11-server-Xorg
xorg-x11-drv-ati-6.9.0-31.fc10.i386
xorg-x11-server-Xorg-1.5.2-8.fc10.i386

The kernel log says twice.
[drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
[drm:drm_buffer_object_validate] *ERROR* Out of aperture space or DRM memory
quota.
Comment 3 Yanko Kaneti 2008-10-26 02:17:20 EDT
Created attachment 321537 [details]
broken image
Comment 4 Yanko Kaneti 2008-10-26 02:22:14 EDT
Created attachment 321538 [details]
Xorg.0.log to go with the previous image
Comment 5 Garry Reisky 2008-10-26 02:40:02 EDT
Created attachment 321540 [details]
Xorg log
Comment 6 Garry Reisky 2008-10-26 02:44:18 EDT
$ rpm -q xorg-x11-drv-ati xorg-x11-server-Xorg
xorg-x11-drv-ati-6.9.0-31.fc10.i386 xorg-x11-server-Xorg-1.5.2-8.fc10.i386

$ uname -r
2.6.27.3-44.fc10.i686

$ lspci -nn | grep Radeon
03:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon R350 [Radeon 9800 Pro] [1002:4e48]
03:00.1 Display controller [0380]: ATI Technologies Inc Radeon R350 [Radeon 9800 Pro] (Secondary) [1002:4e68]
Comment 7 Matěj Cepl 2008-10-26 18:08:43 EDT
This doesn't look like a X crash. Passing to the kernel guys.
Comment 8 Dave Airlie 2008-11-10 00:56:20 EST
Please try xorg-x11-drv-ati -44 + kernel 2.6.27.5-92 from koji to see if this is fixed.
Comment 9 Yanko Kaneti 2008-11-10 07:03:10 EST
(In reply to comment #8)
> Please try xorg-x11-drv-ati -44 + kernel 2.6.27.5-92 from koji to see if this
> is fixed.

the handling of that large background image seems to be fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.