This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468576 - launching problem
launching problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 05:28 EDT by chanueting
Modified: 2009-04-26 09:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-26 09:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New pop up of disc playing since Fedora 9 (28.46 KB, image/png)
2009-03-25 04:28 EDT, chanueting
no flags Details

  None (edit)
Description chanueting 2008-10-26 05:28:50 EDT
Description of problem:
The Audio Disk window would like to import all the songs into the computer after selecting "Open Rhythmbox Music Player".

Version-Release number of selected component (if applicable):
GNOME rhythmbox 0.11.6

How reproducible:
Every time after the insertion of disk

Steps to Reproduce:
1.Insert a disk in the drive
2.Select "Open Rhythmbox Music Player" in the Audio Disk window and press OK
3.
  
Actual results:
The Rhythmbox would try to import all songs in the disk to the list of rhythmbox. And all the details like names of the performers and album lost.

Expected results:
The disk should be played like we select the disk under devices without importing to the computer. Since there is an Extract button in the Rhythmbox, or Sound Juicer could be used.

Additional info:
Comment 1 Bastien Nocera 2008-10-26 20:34:26 EDT
I don't understand your problem. Do you want to set up your system so that it could auto-import inserted audio CDs using Rhythmbox or Sound-Juicer?
Comment 2 chanueting 2008-10-28 07:29:38 EDT
I am sorry for the confusion. I do not mean any of them, but play music of disk without importing.
Comment 3 Bastien Nocera 2009-03-24 13:06:05 EDT
This doesn't make much sense to me.

Rhythmbox never tried to import files directly from CD sources when launched. It would however try to play back the CD.

If you still see this, please give me:
- the output of "rpm -q rhythmbox"
- the output of "ps aux | grep rhythmbox"
- the output of "rhythmbox -d" when launched with the same command as seen in the "ps aux" output.
Comment 4 chanueting 2009-03-25 04:28:44 EDT
Created attachment 336607 [details]
New pop up of disc playing since Fedora 9
Comment 5 chanueting 2009-03-25 04:34:35 EDT
Sorry that I did not update the current status of the problem due to my busy life. There is improvement that Rhythmbox no longer trying to grab files from CD, but at the same time, rhythmbox is not going to play the CD without open the application again and select the disc and play button now. I have no idea whether the new pop up do cause this issue, I think there may be some problems between the pop up and rhythmbox since Fedora 9.
Comment 6 Bastien Nocera 2009-04-24 10:52:58 EDT
I still don't understand the problem. Rhythmbox doesn't import CDs automatically, and it won't try to play them unless you select it in the dialogue.
Comment 7 chanueting 2009-04-26 09:13:25 EDT
Rhythmbox is not going to import CDs automatically in recent builds, but it does not play automatically now after choosing OK from the above pop up. I wonder if this is another bug.
Comment 8 Bastien Nocera 2009-04-26 09:24:48 EDT
It _never_ tried to import CDs automatically.

As for not automatically playing the CD, that's expected (so that people can choose to import the CD instead). If you feel strongly about it not playing CDs when started through nautilus, please file a bug upstream at http://bugzilla.gnome.org

Note You need to log in before you can comment on or make changes to this bug.