Bug 46858 - vga-text install fails in VideoCardInfo()
vga-text install fails in VideoCardInfo()
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 11:15 EDT by Gene Czarcinski
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-29 12:38:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-07-01 11:15:08 EDT
OK, this was done under vmware and I know that RedHat does not support
VMware.  However, this install works fine under 7.1 but fails uner beta1.

This is a nfs network install with disc1 and disc2 copied into a single
directory tree.

The install proceeds until after the nfs server is defined and accessed.

Then I get the following repeatable failure:

Running anaconda - please wait...
Probing for video card:  Traceback (innermost last):
  File "/usr/bin/anaconda", line 358, in ?
    videohw   = videocard.VideoCardInfo()
  File "usr/lib/anaconda/videocard.py", line 288, in __init__
    if info:
NameError: info
install exited abnormally
Comment 1 Brent Fox 2001-07-01 12:38:04 EDT
Does it behave the same way if you do a regular install (i.e. not VmWare)?
Comment 2 Gene Czarcinski 2001-07-01 15:55:02 EDT
I do not have a plain vga-only card (just the simulated on under vmware).
However, using bootnet with the same server on raw hardware works OK.
Comment 3 Brent Fox 2001-07-10 14:44:01 EDT
Then it appears that VMware isn't emulating a generic VGA card properly on your
machine.  This isn't something that we can fix since VMware is closed source.  :(
Comment 4 Eugene Kanter 2001-07-10 16:59:43 EDT
Gene did not say that raw hardware video card is not recognized by the 
installer.

Why are you telling that VMware does not emulate VGA properly?
There are no known cases of improper emulation of VGA hardware. At least
XFree86 VGA16 server works perfectly on VMware.
Comment 5 Gene Czarcinski 2001-07-29 12:37:56 EDT
Mmmm ... I just installed Roswell (beta3) under vmware via an nfs install.  The
text mode worked properly although I could not configure generic 640x480 vga.

The install wored fine.  Since I made zero changes in VMware, I guess it was
something in anaconda afterall!

Note You need to log in before you can comment on or make changes to this bug.