Bug 46859 - 7.1 Update Installer freezes when checking for bad blocks
7.1 Update Installer freezes when checking for bad blocks
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 11:24 EDT by Brian M. Carlson
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-09 19:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian M. Carlson 2001-07-01 11:24:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)

Description of problem:
When I choose Disk Druid's option to check /dev/hda5 (/) for bad blocks when formatting, the actual format freezes about 90 
seconds into it. I am unable to use Ctrl-Alt-Del or kill the X server.

How reproducible:
Always

Steps to Reproduce:
1. Choose Disk Druid (Manual Format)
2. Format /boot (/dev/hda1, 54 MB), / (/dev/hda5, 9611 MB), and swap (/dev/hda6, 168 MB)
3. Set "Check for bad blocks" flag.
4. Go through the rest of the steps (any options, doesn't matter).
	

Actual Results:  When the disk begins to format, about 90 seconds into the format, the system freezes. The progress bar does not 
move,  the X server cannot be killed, and the machine cannot be rebooted with the keyboard.

Expected Results:  The format should complete and bad blocks, if any, should be indicated in the proper place.

Additional info:

I am almost certain that bad blocks exist on my disk. When I tried to perform an upgrade, glibc-common, which I believe was 
located 
in the same place on the disk, failed to install because it could not remove a file. Also, I am using the installer on the RedHat 7.1 
Update CD.
Comment 1 Brent Fox 2001-07-03 12:37:15 EDT
How long did you let the machine sit?  Checking for bad blocks takes a looooong
time...two or three hours is not unusual for large drives.
Comment 2 Brian M. Carlson 2001-07-06 13:16:23 EDT
I let it sit quite a while (an additional 30 minutes or so), but the disk activity light had gone off after only 90 seconds and the mouse would not move. I 
realize the badblocks check takes a long time; I did it on a debian system and it took over an hour with e2fsprogs 1.19, and found 12 bad blocks. It was 
still unable to install after that.
Comment 3 Brian M. Carlson 2001-07-09 19:11:00 EDT
I took the computer in and it appears it is a hardware problem with a bad K6-2. That explains a lot. I'm filing a NOTABUG on this, if that's OK.
Comment 4 Brent Fox 2001-07-17 11:32:32 EDT
Ok.  Too bad about your computer though.  There's nothing more frustrating than
bad hardware...especially when you're not sure if it's the software or the
hardware that has a problem.  I wish that when hardware breaks, it would break
completely instead of just behaving strangely.

Note You need to log in before you can comment on or make changes to this bug.