Bug 4686 - Small %postun bug in mod_php3_pgsql
Small %postun bug in mod_php3_pgsql
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mod_php3 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-24 09:19 EDT by Randy Russell
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-28 01:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Russell 1999-08-24 09:19:04 EDT
This bug concerns the mod_php3_pgsql package that is
available on updates.redhat.com.  This RPM has a %post
procedure that activates the pgsql.so module in
/etc/httpd/php3.ini:

%post pgsql
perl -pi -e 's|^;extension=pgsql.so|extension=pgsql.so|g'
/etc/httpd/php3.ini

There is a corresponding %postun procedure:

%postun pgsql
if [ $1 = 0 ]; then
  perl -pi -e 's|^extension=pgsql.so|;extension=pgqsl.so|g'
/etc/httpd/php3.ini
fi

You'll notice that the replacement string reads "pgqsl.so",
rather than "pgsql.so".  It's a relatively minor problem,
but one that could prove annoying if someone were to
uninstall the package, then try reinstalling it.
Reinstallation would not re-enable the module.
Comment 1 charles 1999-08-26 14:39:59 EDT
Both mod_php3-imap-3.0.9-1.i386.rpm and
mod_php3-pgsql-3.0.9-1.i386.rpm use perl in their postinstall and
postuninstall scripts.  Since those packages are upgrades, most
people who install them will have perl installed and not see a
problem.

However, when used in a system installation from scratch (e.g.,
from an updated distribution CD), perl is not available in
RedHat/instimage/usr/bin and the script fails.  sed is not there
either, but it could be added and used for this purpose in install
scripts instead of perl because of its smaller size.
Comment 2 Preston Brown 1999-08-28 01:32:59 EDT
both problems are fixed in the forthcoming release (6.1).

Note You need to log in before you can comment on or make changes to this bug.