Bug 46860 - partitioning with fdisk, formatting swap with Druid
partitioning with fdisk, formatting swap with Druid
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 11:25 EDT by Jennifer Giles
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 00:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the file that was created after I acquiesced to the system request to save the error report to disk (9.80 KB, text/plain)
2001-07-01 11:31 EDT, Jennifer Giles
no flags Details

  None (edit)
Description Jennifer Giles 2001-07-01 11:25:36 EDT
Description of Problem:
I was installing 7.1, and used the install program to partition my disk. I was using Druid, but when
it came to formatting the swap space, the system would hang. So, I decided to use fdisk. The 
following was printed to my screen and I was told to report it at this website (file attached). Then,
the buttons started getting really picky about what keys they would accept. Tab stopped working,
arrow keys stopped working, an isolated return did nothing, sometimes these keys would print
gobbly-gook to the screen. I finally found that <spacebar>+<enter> worked, and went back to 
rechoose disk druid. After I had gone through this error with fdisk, formatting the swap space via
Druid no longer caused the system to hang, and I was able to complete the install.  

How Reproducible:
I'm not really sure, I had some problems with my hard drive and it's partition table before trying
this install. However, if the hardware is not a factor, then simply start the text install and try to 
partition a drive with fdisk. 

Steps to Reproduce:
1. Start an install of RH 7.1 on a system with a blank or corrupted partition table. Choose text
 or graphical mode, but use a system that does not have enough RAM to use the graphical. 
2. When prompted, choose to manually partition a drive. Make at least one swap partition with
 Druid. When prompted, accept immediate swap formatting. This is where my system hangs.
3. Restart install, and repeat except try to use fdisk. If fdisk does not work then you have 
reproduced my bug. If it does work I don't know what to tell you.

Actual Results:
fdisk doens't work, and Druid only works after fdisk fails.

Expected Results:
That either fdisk or Druid will work the first time they are tried.


Additional Information:
Comment 1 Jennifer Giles 2001-07-01 11:31:27 EDT
Created attachment 22367 [details]
the file that was created after I acquiesced to the system request to save the error report to disk
Comment 2 Brent Fox 2001-07-03 14:31:30 EDT
You are having some very strange errors that makes me think that something
besides fdisk could be wrong.  When the installer crashes, can you press
<Alt><F4> and see if there are any error messages?
Comment 3 Jennifer Giles 2001-07-03 19:21:01 EDT
Actually, now that I've got things installed, I'd rather not take the chance of messing it up again. However, I'm
thinking of setting up a dual-boot system. If I do that I probably will re-install. If the problem re-occurs at that point
I'll try Alt+F4, and let you know what happens.
Comment 4 Brent Fox 2001-07-06 00:46:36 EDT
Ok.  Reopen if you still see problems.

Note You need to log in before you can comment on or make changes to this bug.