Bug 468615 - wlan0 interface handled by hostap doesn't receive arp who-has packets
wlan0 interface handled by hostap doesn't receive arp who-has packets
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 15:16 EDT by Fabrice Bellet
Modified: 2008-10-29 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 19:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2008-10-26 15:16:41 EDT
With latest rawhide, using a prism 2.5 intersil wifi pcmcia card :

kernel-2.6.27.4-47.rc3.fc10.i686
wpa_supplicant-0.6.4-2.fc10.i386
NetworkManager-0.7.0-0.11.svn4201.fc10.i386

I noticed that the interface doesn't receive ARP packets. I also have a bunch of debug messages like this one in my logs, but they don't seem to be related, because they don't appear when the machine is expected to reply ARP requests:

wifi0: could not find TX callback (idx 21845)
Comment 1 John W. Linville 2008-10-27 10:42:12 EDT
Related/duplicate of this?

http://bugzilla.kernel.org/show_bug.cgi?id=11802
Comment 2 Fabrice Bellet 2008-10-27 12:48:05 EDT
This one is not related, but rhbz #468613 is.
And fixing the padding as suggested still causes the arp packets to be ignored.
Comment 3 John W. Linville 2008-10-27 13:06:44 EDT
What is the last kernel version that worked?  There hasn't been much happening with that driver...
Comment 4 Fabrice Bellet 2008-10-29 19:46:04 EDT
Sorry for the false alarm. After investigation, this behaviour was not related to hostap, but to the multicast rate forced to G-mode on my openwrt box, while my prism2 card can only do B-mode...

Note You need to log in before you can comment on or make changes to this bug.