This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 468618 - over-enthusiastic subpackaging
over-enthusiastic subpackaging
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: un-core-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-26 15:28 EDT by Nicolas Mailhot
Modified: 2009-08-31 05:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 05:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-10-26 15:28:41 EDT
While splitting font packages is generally good, separating regular and bold faces of the same font in different packages is a tad over the top.

Please keep batang and batang bold in the same package (reiterate for other un core fonts)

(at the same time, it's awesome you've managed to package a beast like the un fonts given all the problems you had to solve)
Comment 1 Nicolas Mailhot 2008-10-26 15:29:52 EDT
(and same for light when it's available like for dinaru)
Comment 2 Jens Petersen 2008-10-27 22:41:15 EDT
Do you think we should make an exception for dotum though since it will pull in another 2.5MB for all users?

4.6M  un-core-fonts-dotum-1.0.2-0.6.080608.fc10.noarch.rpm
2.5M  un-core-fonts-dotumbold-1.0.2-0.6.080608.fc10.noarch.rpm
Comment 3 Nicolas Mailhot 2008-10-27 23:45:10 EDT
I don't like exceptions much, you end up removing them later generally. And I tend to believe that anyone who's actually interested in dotum will want the bold too.

I suppose dotum is a special case because want to install korean support for everyone by default, even for people who didn't ask for it (but is it really ok to provide korean without bold when we have it available?). If we're that short of space for F10 you can make it an exception, but IMHO it will end up in the default install set in a few releases anyway.
Comment 4 Nicolas Mailhot 2008-11-09 16:22:12 EST
BTW if the problem is that the current macros used in this package want to take a single font file as argument, then the subpackaging macro I wrote in dejavu yesterday could be used instead.

I must admit I was thinking very hard about the un font packages when I wrote them.
Comment 5 Bug Zapper 2008-11-25 23:16:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Jens Petersen 2009-06-25 23:48:44 EDT
Actually it is worse that that since currently the main packages also contain the bold (and light) fonts...
Comment 7 Jens Petersen 2009-06-26 02:25:17 EDT
Should be fixed in 1.0.2-0.9.080608.

Note You need to log in before you can comment on or make changes to this bug.