Bug 468644 - wrapped acroread stays running after browsing away from page, grows forever and eventually hoses machine
wrapped acroread stays running after browsing away from page, grows forever a...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 22:14 EDT by Jonathan Kamens
Modified: 2008-10-27 05:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 05:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-10-26 22:14:21 EDT
I have nspluginwrapper-1.1.2-4.fc10.i386.rpm, AdobeReader_enu-8.1.2_SU1-1.i486.rpm (fixed by hand to force the RPM install to work properly as I described in another bug), and mostly other up-to-date packages from Rawhide.

When I configure firefox to view PDF files inside a browser window using nspluginwrapper, then browse to a PDF file, then hit the back button to go back to the previous page, npviewer.bin exists, but acroread does not.  Instead, it stays running forever, increasing in memory size little by little until eventually it is so large that it hoses the entire machine.
Comment 1 Martin Stransky 2008-10-27 05:12:16 EDT
It's a bug in Adobe pdf plugin...I can reproduce it without nsplguinwrapper installed. I'm afraid I can't fix that bug in nspluginwrapper because adobe reader runs as different process and it's separated from the plugin.

Note You need to log in before you can comment on or make changes to this bug.