Bug 468653 - iml-devel depends upon a base package iml that doesn't exist
iml-devel depends upon a base package iml that doesn't exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iml (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 03:01 EDT by Alex Lancaster
Modified: 2008-10-27 20:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 20:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-10-27 03:01:37 EDT
For some reason iml doesn't include the proper base package iml, but the -devel subpackage is dependent on it:

%package        devel
Summary:        Development files for %{name}
Group:          Development/Libraries
Requires:       %{name} = %{version}-%{release}
Provides:       %{name}-static = %{version}-%{release}

this causes broken deps in rawhide: 

Broken deps for i386
----------------------------------------------------------
         iml-devel-1.0.2-3.fc10.i386 requires iml = 0:1.0.2-3.fc10

I'm not sure what the packager intended but this is whole package really broken, please fix ASAP.  This really should have been picked up in review.
Comment 1 Conrad Meyer 2008-10-27 19:42:24 EDT
Fixed in rawhide [0]. Closing. Re-open if you feel it wasn't fixed to your satisfaction.

[0]: http://koji.fedoraproject.org/koji/taskinfo?taskID=908166
Comment 2 Alex Lancaster 2008-10-27 20:10:32 EDT
Thanks, but it looks like you only did a build for F-11 (note the dist-f11 tag in that build), not current rawhide (soon to be F-10).

Re-opening until fixed for rawhide.
Comment 3 Conrad Meyer 2008-10-27 20:18:32 EDT
Builds for F-9 and F-10 in progress.
Comment 5 Alex Lancaster 2008-10-27 20:28:07 EDT
Thansk.  Looks good.  Go ahead and close.  If there are problems with broken deps in rawhide after tonight's compose, I'll re-open the bug.
Comment 6 Conrad Meyer 2008-10-27 20:32:49 EDT
Thanks for filing the bug.

Note You need to log in before you can comment on or make changes to this bug.