Bug 468655 - Logwatch update overwrites custom config files
Logwatch update overwrites custom config files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 04:29 EDT by Simon Andrews
Modified: 2008-11-07 21:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 21:10:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Andrews 2008-10-27 04:29:13 EDT
Description of problem:
When updating to the latest logwatch the changes I had made to 
/usr/share/logwatch/default.conf/logwatch.conf were overwritten and no backup of the old version was saved.

Version-Release number of selected component (if applicable):
logwatch-7.3.6-25.fc9.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install older version of logwatch (eg logwatch-7.3.6-22.fc9.noarch)
2. Make changes to /usr/share/logwatch/default.conf/logwatch.conf
3. Update to logwatch-7.3.6-25.fc9.noarch
  
Actual results:
The custom logwatch.conf is overwritten, losing all changes and no .rpmsave file is generated


Expected results:
Either the existing conf file is left and the new conf file is installed as an rpmnew, or if there is a change to the file structure the old file is preserved as a rpmsave file.

Additional info:
Comment 1 Fedora Update System 2008-10-30 05:47:52 EDT
logwatch-7.3.6-26.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/logwatch-7.3.6-26.fc9
Comment 2 Fedora Update System 2008-10-31 06:26:33 EDT
logwatch-7.3.6-26.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update logwatch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9328
Comment 3 Simon Andrews 2008-11-04 11:03:59 EST
Just to note that the instructions given in #2 are incorrect (I wondered why the update hadn't shown up).

New updates for F9 now appear in updates-testing-newkey, not updates-testing.

Anyway, having installed the update the problem seems to be fixed.  I've added a comment to bodhi saying it works now.

Thanks for fixing this.
Comment 4 Fedora Update System 2008-11-07 21:10:30 EST
logwatch-7.3.6-26.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.