Bug 468679 - compiz often fails to start on initial login
compiz often fails to start on initial login
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 08:38 EDT by Jeff Layton
Modified: 2018-04-11 03:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 08:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors (11.42 KB, text/plain)
2008-10-27 08:38 EDT, Jeff Layton
no flags Details
xorg.conf from intel machine (640 bytes, text/plain)
2008-10-30 08:58 EDT, Jeff Layton
no flags Details
xsession-errors from intel machine (2.81 KB, text/plain)
2008-10-30 09:01 EDT, Jeff Layton
no flags Details
Xorg.0.log (88.44 KB, text/plain)
2008-10-30 09:02 EDT, Jeff Layton
no flags Details
dmesg.out (26.43 KB, text/plain)
2008-10-30 09:04 EDT, Jeff Layton
no flags Details
Xorg.0.log from X start with no xorg.conf (57.25 KB, text/plain)
2008-10-30 09:18 EDT, Jeff Layton
no flags Details
display corruption after switching to compiz and reloading window manager (1.21 MB, image/png)
2009-01-29 07:31 EST, Jeff Layton
no flags Details

  None (edit)
Description Jeff Layton 2008-10-27 08:38:16 EDT
Created attachment 321609 [details]
.xsession-errors

Usually, on initial login compiz fails to start, leaving my desktop running without a window manager. Using the "Reload window manager" selection in the fusion-icon applet typically gets compiz started correctly. Because of this, it seems like a race of some sort.

This happens on both my home workstation (using proprietary nvidia graphics driver) and on my workstation at work (Intel graphics). The intel machine also seems to often get hit with the "whitescreen" problem, but that may not be related...

I've attached my .xsession-errors file from my home w/s (nvidia graphics). I'm using:

compiz-manager-0.6.0-8.fc10.noarch
compiz-gnome-0.7.6-15.fc10.x86_64
compiz-fusion-gnome-0.7.6-7.fc10.x86_64
compiz-0.7.6-15.fc10.x86_64
compiz-fusion-0.7.6-7.fc10.x86_64
compizconfig-python-0.7.6-1.fc10.x86_64
compizconfig-backend-gconf-0.7.6-1.fc10.x86_64
fusion-icon-qt-0.1.0-0.3.5e2dc9git.fc10.noarch
fusion-icon-0.1.0-0.3.5e2dc9git.fc10.noarch
ccsm-0.7.6-2.fc10.noarch

...I've had this problem during all of F9 and am still seeing it in F10 (maybe also during F8? Not sure...)

Other info available upon request. I should also be able to test packages if needed...
Comment 1 Matěj Cepl 2008-10-28 19:02:52 EDT
So, first things first -- don't talk to me about nvidia binary-only driver. It is unsupported, and especially in case of OpenGL we cannot do much about it, because nvidia replaces even parts of GL implementation with their own stuff. So, please, let's talk just about your intel computer at work.

Please attach your X server config file (/etc/X11/xorg.conf), X server log file (/var/log/Xorg.*.log), /var/log/dmesg, and ~/.xsession-errors from that computer to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jeff Layton 2008-10-30 08:58:07 EDT
Created attachment 321926 [details]
xorg.conf from intel machine
Comment 3 Jeff Layton 2008-10-30 09:01:10 EDT
Created attachment 321927 [details]
xsession-errors from intel machine
Comment 4 Jeff Layton 2008-10-30 09:02:01 EDT
Created attachment 321928 [details]
Xorg.0.log
Comment 5 Jeff Layton 2008-10-30 09:04:14 EDT
Created attachment 321929 [details]
dmesg.out

/var/log/dmesg doesn't show the DRM initialization, so here's the actual output from dmesg after boot and login
Comment 6 Jeff Layton 2008-10-30 09:18:17 EDT
Created attachment 321930 [details]
Xorg.0.log from X start with no xorg.conf

I updated my workstation at work to F10 this morning and am getting different results. compiz no longer works at all and gives a black screen on login. I suspect the problem may be the DRM error messages that are showing up in the kernel ring buffer (or some other Intel X driver related problem).

I also tried booting the machine with no xorg.conf file and the display completely froze soon after displaying the login screen. ctrl-alt-backspace had no effect.

Attached is the Xorg.0.log from that attempt.
Comment 7 Bug Zapper 2008-11-25 23:17:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jeff Layton 2009-01-29 07:31:55 EST
Created attachment 330347 [details]
display corruption after switching to compiz and reloading window manager

More recent updates to f10 show a different problem when I enable compiz on my machine with intel video. When I use the panel applet to switch to compiz the window manager still immediately exits and leaves me with no window bars. When I then use the applet to reload the window manager, I get a completely scrambled screen.

Attaching a screenshot of what I see after reloading the window manager. Mousing over elements in the menu bars or windows seems to make the elements display correctly but there doesn't seem to be any way to force a redraw of the entire screen.

Let me know if there is other info that would be helpful.
Comment 9 Jeff Layton 2009-09-16 06:48:59 EDT
I think I found the cause of the initial problem...

metacity had the compositing_manager option enabled in gconf. I believe that was preventing compiz from taking over the compositing manager at login. After disabling that it seems to work.

On the other issue with intel video, F11 doesn't currently give any display corruption when I enable compiz, but it does completely hang the box after a period of time. That's a separate issue however, so we can deal with that separately.

I'm not sure what the solution is here...maybe metacity should be fixed to hand over control to compiz when it starts?
Comment 11 Matěj Cepl 2009-11-17 07:01:20 EST
Switching incorrect assignees to the default one.
Comment 12 Jeff Layton 2009-11-17 07:09:45 EST
FWIW, compiz seems to work correctly with F12 now...

The issue of contention between metacity and compiz for the compositing manager is still a problem that needs to be solved however.
Comment 13 Matěj Cepl 2009-11-17 08:01:12 EST
(In reply to comment #12)
> FWIW, compiz seems to work correctly with F12 now...
> 
> The issue of contention between metacity and compiz for the compositing manager
> is still a problem that needs to be solved however.  

metacity as a compositing manager is unsupported hack which is there left undocumented for those who dare to try. I don't think we will bother with doing anythig to support it.

Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.