Bug 468695 - Spits out errors for USB webcam mic
Spits out errors for USB webcam mic
Status: CLOSED DUPLICATE of bug 469416
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 10:24 EDT by Bastien Nocera
Modified: 2009-02-04 05:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 05:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-10-27 10:24:30 EDT
W: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
W: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
W: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 18.00 dB to 18.00 dB which makes no sense.

The device is a UVC webcam, and the device uses USB audio.

$ cat /proc/asound/cards 
 0 [ICH7           ]: ICH4 - Intel ICH7
                      Intel ICH7 with AD1981B at irq 23
 1 [U0x46d0x990    ]: USB-Audio - USB Device 0x46d:0x990
                      USB Device 0x46d:0x990 at usb-0000:00:1d.7-2, high speed

$ amixer -c 1
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 3072
  Mono: Capture 1536 [50%] [18.00dB] [on]
Comment 1 Lennart Poettering 2008-10-27 10:48:05 EDT
Yepp. PA is right. Your dB range is 3072 steps between 18 to 18 dB. Which of course is bogus. Your USB hardware apparently exports bogus dB information. The USB kernel driver should detect bogus dB data and not export that to userspace.

Reassigning to kernel, since this should be filtered out by the kernel drivers, not by PA.
Comment 2 Hans de Goede 2008-10-27 14:36:46 EDT
This is an alsa problem, not a v4l problem, re-assigning.
Comment 3 Bug Zapper 2008-11-25 23:17:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jaroslav Kysela 2009-02-04 05:43:45 EST

*** This bug has been marked as a duplicate of bug 469416 ***

Note You need to log in before you can comment on or make changes to this bug.