Bug 468699 - pvrusb2 driver lockup: fixed upstream
pvrusb2 driver lockup: fixed upstream
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 10:45 EDT by Scott Doty
Modified: 2008-10-31 03:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 03:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Doty 2008-10-27 10:45:55 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.2) Gecko/2008100707 Fedora/3.0.2-1.fc10 Firefox/3.0.2

The pvrusb2 driver in kernel-2.6.27.3-39.fc10.x86_64 has a lockup issue which causes module operations to "stick", leaving (say) "modprobe -r" in "D" state, according to ps.

There is a fix upstream, which is in Linux 2.6.27.4

Meanwhile, the workaround is to load the module with the "initusbreset=0" option.  I did this by creating a new file, /etc/modprobe.d/pvrusb2, and adding a single line: "options pvrusb2 initusbreset=0" (no quotes).


Reproducible: Always

Steps to Reproduce:
1.Boot rawhide with Hauppauge WinTV PVR USB2 attached.
or
1.Hotplug Hauppauge WinTV PVR USB2.

Actual Results:  
pvrusb2 module fails to work -- attempt to "modprobe -r pvrusb2" leaves modprobe process in " D " state, udev gets frozen, module subsystem in kernel gets frozen, dogs living with cats, panic in the streets.


Expected Results:  
Expected operational Hauppauge WinTV PVR USB2

the pvrusb2 mailing list has a recent thread about this, culminating in a fix in kernel 2.6.27.4.
Comment 1 Chuck Ebbert 2008-10-31 03:23:56 EDT
2.6.27.4 has been in rawhide since Oct 24 when 2.6.27.4-rc1 went in.

Note You need to log in before you can comment on or make changes to this bug.