Bug 468702 - No wireless available for downloading stage2
No wireless available for downloading stage2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 11:04 EDT by Andrew Overholt
Modified: 2014-01-21 18:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 12:55:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2008-10-27 11:04:03 EDT
I recently tried a preupgrade of a laptop from Fedora 8 to Fedora 9.  Things went well, but there wasn't enough disk space to download stage2 before starting the upgrade.  Upon restarting, the upgrade process began but couldn't download stage2 due to there being no wired network connection and wireless apparently not working.  Can something be done about this situation?
Comment 1 Will Woods 2008-10-27 12:55:20 EDT
In short: no.

In long: anaconda probably won't ever be able to support/configure all the super-fun wireless encryption modes and network setups that your normal desktop experience can. So, ideally, you need to get all the data *before* rebooting, so we don't need to worry about that.

If you can't get stage2 before rebooting, you have some workarounds available - free some space in /boot (or expand it), put stage2 on (e.g.) a USB device and fetch it from there, configure a network connection that anaconda knows about,  etc. In fact anaconda's stage1 *can* handle certain simple wireless networks - you'll need to add something like:
  allowwireless essid=<essid> wepkey=<key>
to your boot commandline. See http://fedoraproject.org/wiki/Anaconda/Options for details.

But beyond that? Automagically configuring your wireless from stage1 is Not Gonna Happen, sadly. It's insanely complex and it's far more sensible to just avoid using the network at all.

Closing WONTFIX.
Comment 2 Andrew Overholt 2008-10-27 13:07:51 EDT
Understood.  Perhaps we should warn that if wireless is the user's only option they should get stage2 somehow before rebooting?

Note You need to log in before you can comment on or make changes to this bug.