Bug 468707 - avahi-daemon starts too late
avahi-daemon starts too late
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 468709
  Show dependency treegraph
 
Reported: 2008-10-27 11:39 EDT by Tim Waugh
Modified: 2008-12-11 14:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 14:18:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-10-27 11:39:55 EDT
Description of problem:
The avahi-daemon initscript starts at priority 96, but this is too late for cupsd.  cupsd needs to start before haldaemon but after avahi-daemon, so avahi-daemon must start at priority 26 at the latest.

Version-Release number of selected component (if applicable):
avahi-0.6.22-10.fc9

How reproducible:
100%

Steps to Reproduce:
1.Boot with a newly-connected printer switched on.
  
Actual results:
Printer is not automatically configured.

Expected results:
Printer is automatically configured.

Additional info:
The reason is that haldaemon (which launches hal_lpadmin) starts before cupsd, so the printer cannot be configured.
Comment 1 Lennart Poettering 2008-12-11 14:18:30 EST
Avahi upstream is now moved to prio 24. This will shortly be available in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.