Bug 468714 - pydev 1.3.23-1.fc10 doesn't work
pydev 1.3.23-1.fc10 doesn't work
Status: CLOSED DUPLICATE of bug 458626
Product: Fedora
Classification: Fedora
Component: eclipse-pydev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Nowak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 12:02 EDT by Mads Kiilerich
Modified: 2013-03-07 21:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 16:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-27 12:02:08 EDT
Description of problem:

Yes, the summary shows how NOT to make a summary, but I can't describe it better.

With old eclipse-pydev-1.3.22-1.fc10.noarch pydev works, for example there is File -> New -> Project -> Pydev

With recent update to 1.3.23-1.fc10 pydev doesn't work at all; it seems like it isn't registered at all.

Downgrading to old pydev makes it work again.

I file it as urgent because it is a showstopper for my use of pydev, seems to be a general problem and I don't know a workaround. I hope to be proven wrong.


Version-Release number of selected component (if applicable):

eclipse-pydev.noarch 1:1.3.23-1.fc10
Comment 1 Andrew Overholt 2008-10-27 12:12:12 EDT
This sounds like bug #458626

Alex:  please see if you can identify what's causing this situation.

Mads:  can you please try mv ~/.eclipse{,.bak20081027-pydev} and re-start and see if it's picked up?
Comment 2 Alexander Kurtakov 2008-10-27 12:41:46 EDT
Mads: It is working on my PC.
Can you post the output of "rpm -qa|grep eclipse"?
And if there are plugins which are not updated to rawhide version, please update them and tell me if pydev is working after that.
Comment 3 Mads Kiilerich 2008-10-27 13:17:14 EDT
It might be the same as bug #458626 and thus a general eclipse issue, but FWIW in my setup it is related to the new pydev.

Without .eclipse (and thus automatically creating a new one) the new pydev works fine.

I can reproduce the problem by downgrading pydev and copying the old .eclipse back. 

Is there anything I should do and look for?

I am fully uptodate:
eclipse-cdt-5.0.0-10.fc10.i386
eclipse-cdt-sdk-5.0.0-10.fc10.i386
eclipse-changelog-2.6.3-1.fc10.i386
eclipse-checkstyle-4.0.1-11.fc10.i386
eclipse-demos-0.0.1-2.fc8.noarch
eclipse-ecj-3.4.1-5.fc10.i386
eclipse-egit-0.3.1.20081022-3.fc10.noarch
eclipse-epic-0.6.25-1.fc10.i386
eclipse-gef-3.3.0-2.fc9.i386
eclipse-gef-examples-3.3.0-2.fc9.i386
eclipse-gef-sdk-3.3.0-2.fc9.i386
eclipse-jdt-3.4.1-5.fc10.i386
eclipse-mylyn-3.0.3-2.fc10.noarch
eclipse-mylyn-java-3.0.3-2.fc10.noarch
eclipse-mylyn-pde-3.0.3-2.fc10.noarch
eclipse-mylyn-trac-3.0.3-2.fc10.noarch
eclipse-pde-3.4.1-5.fc10.i386
eclipse-photran-4.0.0-0.b4.fc10.3.i386
eclipse-platform-3.4.1-5.fc10.i386
eclipse-pydev-1.3.23-1.fc10.noarch
eclipse-quickrex-3.5.0-9.fc10.noarch
eclipse-rcp-3.4.1-5.fc10.i386
eclipse-rpm-editor-0.4.0-5.fc10.i386
eclipse-setools-3.3.2.4-3.fc10.i386
eclipse-slide-1.3.9-3.fc10.noarch
eclipse-subclipse-1.2.4-12.fc10.noarch
eclipse-subclipse-book-1.2.4-12.fc10.noarch
eclipse-swt-3.4.1-5.fc10.i386
icu4j-eclipse-3.8.1-4.fc10.i386
maven2-plugin-eclipse-2.0.4-10.15.fc10.i386
tomcat5-jasper-eclipse-5.5.27-4.9.fc10.noarch

By the way, after yumming eclipse I often get an error message about unreadable workspace. Then I remove .eclipse and spends some time configuring eclipse properly again.

And after killing eclipse the workspace can't be read. Simply quitting eclipse and restarting "solves" that.

Both seems like similar problems. I haven't filed or search for bugs on it; eclipse is so huge ;-)
Comment 4 Mads Kiilerich 2008-10-27 13:20:03 EDT
By the way, when I start eclipse I always get
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles

I don't know if that is eclipse being too verbose or it points at a real problem. But eclipse/pydev usually works great, and if it was serious I would assume that it complained harder ...
Comment 5 Andrew Overholt 2008-10-27 14:04:20 EDT
(In reply to comment #4)
> By the way, when I start eclipse I always get
> CompilerOracle: exclude
> org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
> CompilerOracle: exclude
> org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
> CompilerOracle: exclude
> org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
> CompilerOracle: exclude
> org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
> CompilerOracle: exclude
> org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
> CompilerOracle: exclude
> org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles

This is just coming from OpenJDK.  We're instructing the JIT (just-in-time compiler) to not compile those methods due to errors when they are.
Comment 6 Andrew Overholt 2008-10-27 14:07:13 EDT
(In reply to comment #3)
> Is there anything I should do and look for?

You could try running from a terminal with the additional arguments of "-consolelog" and maybe even "-consolelog -debug" if you want lots of output :)  Something is going wrong somewhere in the update manager picking up new stuff being in /usr/lib{,64}/eclipse/dropins (or maybe /usr/share/eclipse/dropins).

> eclipse-gef-3.3.0-2.fc9.i386
> eclipse-gef-examples-3.3.0-2.fc9.i386
> eclipse-gef-sdk-3.3.0-2.fc9.i386

Try removing these and see if it still happens.

> By the way, after yumming eclipse I often get an error message about unreadable
> workspace. Then I remove .eclipse and spends some time configuring eclipse
> properly again.

Maybe you killed it the last time you ran it and it left a .lock file around?

Thanks for helping us track this down.
Comment 7 Alexander Kurtakov 2008-10-27 14:23:47 EDT
Can you post your ~/.eclipse/org.eclipse.platform-*/
configuration/p2 and configuration/org.eclipse.equinox.simpleconfigurator both before and after updating pydev?
Comment 8 Mads Kiilerich 2008-10-27 16:21:52 EDT
(20:59:43) akurtakov__: what you are seeing is really the problem overholt suggested
(21:00:12) akurtakov__: so can you close it as duplicated or i should do it
(21:00:34) akurtakov__: we are working on this problem with upstream so fix should come soon

*** This bug has been marked as a duplicate of bug 458626 ***
Comment 9 Mads Kiilerich 2008-10-27 19:33:48 EDT
FYI, my minimal testcase:
1. nothing eclipsish installed, no .eclipse
2. yum install eclipse-pydev-1.3.22-1.fc10.noarch.rpm
3. start eclipse on new workspace and exit
4. install 1.3.23
5. start eclipse on the workspace and exit
6. install 1.3.24
7. start eclipse on the workspace - and no pydev

Workaround: install "something else", or run eclipse -clean
Comment 10 Jens Petersen 2008-10-27 21:46:44 EDT
Mads, if bug 458626 is not fixed for you, can you change it back to ASSIGNED?
Comment 11 Mads Kiilerich 2008-10-28 05:26:28 EDT
Jens, sure I could and would, but ... 
* 458626 has some confusion and workarounds but no fix and hasn't been closed, so I don't see how me seeing "the same" makes it less duplicate
* akurtakov who owns 458626 and debugged my problem through IRC told me that it was a duplicate, so I don't know who to follow ... please let me know when you agree

Note You need to log in before you can comment on or make changes to this bug.