Bug 468747 - When converting FLAC or ogg files, speed is always unknown
When converting FLAC or ogg files, speed is always unknown
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus-sound-converter (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 15:49 EDT by Espen Stefansen
Modified: 2008-10-27 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 16:03:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Espen Stefansen 2008-10-27 15:49:29 EDT
Description of problem:
When converting FLAC or ogg files, speed is always unknown. It only works when converting mp3 files.

Version-Release number of selected component (if applicable):
nautilus-sound-converter-0.7.0-1.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1. Convert file
2.
3.
  
Actual results:
Speed: Unknown

Expected results:
Should show estimated time.

Additional info:
Comment 1 Brian Pepple 2008-10-27 16:03:38 EDT
This is because neither of these file formats allows querying of the file duration or position.  This is something that will need to be fixed in the respective gst-plugins to provide these capabilities, so I'm marking this as NOTABUG.  If I can find some free time (I can alway hope), I'll look at working on adding this to the respective gst-plugins.

Note You need to log in before you can comment on or make changes to this bug.