Bug 468779 - sugar gets all sticky
sugar gets all sticky
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 18:42 EDT by Tom Horsley
Modified: 2015-01-14 18:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 09:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-10-27 18:42:06 EDT
Description of problem:

I normally run a "User script" login session, with a ~/.xsession file
driving everything I want to do.

I decided to see what sugar was like, so at the gdm login screen, I
selected a sugar session. That did indeed bring up the absolutely
horrible sugar session. Five minutes is more than enough to convince
me I'd never want to see it again as long as I live :-).

I log out (which is highly non-trivial since the logout button is
described with the word "restart" - a word with completely different
meaning everywhere else in the universe).

I log in again, selecting "User Script" as the session to use.

Lo and behold! The sugar interface comes up again. I try a couple of
more times, and I keep getting sugar (in fact, the session chooser
button keeps showing sugar as the default in the gdm screen as well).

I finally select KDE, login, and actually get a KDE session. I logout
from KDE, select "User script" again, and finally, it is back to running
my ~/.xsession script.

Version-Release number of selected component (if applicable):
sugar-0.82.9-1.fc10.x86_64
xorg-x11-xinit-session-1.0.9-4.fc10.x86_64

How reproducible:
My entire experience is documented above - it certainly seemed stuck
several times till I logged in with a KDE session.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Stuck in sugar

Expected results:
Switch back to ~/.xsession when I say so.

Additional info:
Comment 1 Marco Pesenti Gritti 2008-10-27 20:01:07 EDT
Sounds like a gdm bug to me, sugar doesn't do anything special other than providing a session desktop file.

"Restart" is a bug which is already filed upstream.
Comment 2 Matthias Clasen 2008-10-28 00:55:42 EDT
Can you repeat that (sorry that you'll have to see sugar again...) and take note of the content of ~/.dmrc at the various steps ?
Comment 3 Tom Horsley 2008-10-28 17:22:10 EDT
Looks like I can't reproduce this. I tried doing the exact same sequence
(as near as I could remember) and this time it correctly switched back
to user script the first time I asked it to.

The ~/.dmrc file went from

[Desktop]
Session=xinit-compat

to

[Desktop]
Session=sugar

and back to

[Desktop]
Session=xinit-compat

just as you'd expect.
Comment 4 Simon Schampijer 2008-11-17 09:40:01 EST
Can we close this then - as you can not reproduce it?
Comment 5 Ray Strode [halfline] 2008-11-17 09:45:53 EST
Yea, let's close this one out.

Tom, if you hit it again, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.