Bug 468785 - ERROR with rpm_check_debug vs depsolve:
Summary: ERROR with rpm_check_debug vs depsolve:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-27 23:36 UTC by Andy Lawrence
Modified: 2014-01-21 23:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 04:03:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum with debug enabled (7.50 KB, application/octet-stream)
2008-10-29 22:22 UTC, Andy Lawrence
no flags Details
test output (10.74 KB, application/octet-stream)
2008-10-31 15:46 UTC, Andy Lawrence
no flags Details
More debug (34.41 KB, application/octet-stream)
2008-11-01 12:23 UTC, Andy Lawrence
no flags Details
Debug #3 (18.60 KB, application/x-gzip)
2008-11-01 20:51 UTC, Andy Lawrence
no flags Details
debug #4 (38.67 KB, application/octet-stream)
2008-11-02 12:13 UTC, Andy Lawrence
no flags Details

Description Andy Lawrence 2008-10-27 23:36:07 UTC
Description of problem:

Yum error:
Packages skipped because of dependency problems:
    compat-db45-4.5.20-5.fc10.i386 from rawhide
    rpm-4.6.0-0.rc1.5.i386 from rawhide
    rpm-build-4.6.0-0.rc1.5.i386 from rawhide
    rpm-devel-4.6.0-0.rc1.5.i386 from rawhide
    rpm-libs-4.6.0-0.rc1.5.i386 from rawhide
    rpm-python-4.6.0-0.rc1.5.i386 from rawhide

Dependencies Resolved
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 181, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 356, in doTransaction
    self.listTransaction())
  File "/usr/share/yum-cli/output.py", line 797, in listTransaction
    evr = txmbr.po.printVer()
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 149, in __getattr__
    raise KeyError, str(e)
KeyError: 'no such column: po'
[root@localhost ~]# 

Version-Release number of selected component (if applicable):
yum-3.2.20-1.fc10.noarch


How reproducible:
Every time on x64 System

Steps to Reproduce:
1.  "Yum -y update" with 10-27-08 Rawhide

  
Actual results:


Expected results:


Additional info:

Comment 1 Andy Lawrence 2008-10-27 23:47:44 UTC
My bad, I lied!

This was done with "yum -y --skip-broken update"!

Today's Rawhide completed fine with "yum -y --skip-broken --exclude=rpm* --exclude=compat* update"

Comment 2 James Antill 2008-10-28 04:03:31 UTC
This is fixed in upstream commit: 5e405ec2e6651dc828c9b47075b6867a7e145536

As a quick fix you can goto /usr/share/yum-cli/output.py search for self.skipped_packages and replace it with [].

Comment 3 James Antill 2008-10-28 04:10:17 UTC
 Given this makes --skip-broken unusable in 3.2.20, I've committed and built:

yum-3.2.20-2.fc10
http://koji.fedoraproject.org/koji/taskinfo?taskID=908488

...should be in rawhide tomorrow.

Comment 4 James Antill 2008-10-28 04:25:36 UTC
Actually, it's this koji task:

http://koji.fedoraproject.org/koji/taskinfo?taskID=908500

Comment 5 Andy Lawrence 2008-10-29 20:40:35 UTC
Doen with yum -y --skip-broken update.  Note the yum version at the bottom.

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libdb-4.3.so is needed by (installed) cyrus-sasl-lib-2.1.22-18.fc10.i386
libdb-4.5.so is needed by (installed) rpm-libs-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-devel-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-build-4.6.0-0.rc1.3.i386
libdb-4.3.so is needed by (installed) cyrus-sasl-lib-2.1.22-18.fc10.i386
libdb-4.5.so is needed by (installed) rpm-libs-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-devel-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-build-4.6.0-0.rc1.3.i386
Complete!
(1, [u'Please report this error in bugzilla'])
[root@localhost ~]# rpm -qa yum
yum-3.2.20-2.fc10.noarch
[root@localhost ~]#

Comment 6 seth vidal 2008-10-29 20:48:57 UTC
3.2.20-3 has the fixes, 3.2.20-2 didn't have all of them.

Comment 7 Andy Lawrence 2008-10-29 21:58:00 UTC
Uh:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libdb-4.3.so is needed by (installed) cyrus-sasl-lib-2.1.22-18.fc10.i386
libdb-4.5.so is needed by (installed) rpm-libs-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-devel-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-build-4.6.0-0.rc1.3.i386
libdb-4.3.so is needed by (installed) cyrus-sasl-lib-2.1.22-18.fc10.i386
libdb-4.5.so is needed by (installed) rpm-libs-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-devel-4.6.0-0.rc1.3.i386
libdb-4.5.so is needed by (installed) rpm-build-4.6.0-0.rc1.3.i386
Complete!
(1, [u'Please report this error in bugzilla'])
[root@localhost ~]# rpm -qa yum
yum-3.2.20-3.fc10.noarch
[root@localhost ~]#

Comment 8 Andy Lawrence 2008-10-29 22:22:52 UTC
Created attachment 321877 [details]
yum with debug enabled

Complete output with yum -y -d 3 --skip-broken update

Comment 9 Tim Lauridsen 2008-10-30 06:11:14 UTC
could you post the output from

yum update -d4 compat-db46

Comment 10 Andy Lawrence 2008-10-30 09:58:47 UTC
[root@localhost ~]# yum update -d4 compat-db46
"blacklist" plugin is disabled
"whiteout" plugin is disabled
Loaded plugins: fastestmirror, presto, refresh-packagekit
Running "config" handler for "presto" plugin
Config time: 0.762
Running "init" handler for "fastestmirror" plugin
Yum Version: 3.2.20
COMMAND: yum update -d4 compat-db46 
Installroot: /
Ext Commands:

   compat-db46
Setting up Package Sacks
Running "postreposetup" handler for "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * livna-development: rpm.livna.org
 * rpmfusion-free-rawhide: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-rawhide: mirrors.cat.pdx.edu
Running "postreposetup" handler for "presto" plugin
Setting up and reading Presto delta metadata
livna-development                                        | 2.1 kB     00:00     
No Presto metadata available for livna-development
rpmfusion-free-rawhide                                   | 2.7 kB     00:00     
rpmfusion-free-rawhide/primary_db                        | 238 kB     00:02     
No Presto metadata available for rpmfusion-free-rawhide
rpmfusion-nonfree-rawhide                                | 2.7 kB     00:00     
No Presto metadata available for rpmfusion-nonfree-rawhide
rawhide                                                  | 2.9 kB     00:00     
pkgsack time: 6.724
Reading Local RPMDB
rpmdb time: 0.000
Setting up Update Process
Building updates object
up:Obs Init time: 0.435
up:simple updates time: 0.240
up:obs time: 0.009
up:condense time: 0.000
updates time: 3.002
Resolving Dependencies
--> Running transaction check
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
rpm-4.6.0-0.rc1.3.i386 requires: libdb-4.5.so
--> Processing Dependency: libdb-4.5.so for package: rpm
Searching pkgSack for dep: libdb-4.5.so
Matched compat-db45-4.5.20-5.fc10.i386 to require for libdb-4.5.so
rpm-build-4.6.0-0.rc1.3.i386 requires: libdb-4.5.so
--> Processing Dependency: libdb-4.5.so for package: rpm-build
Quick matched compat-db45-4.5.20-5.fc10.i386 to require for libdb-4.5.so
rpm-libs-4.6.0-0.rc1.3.i386 requires: libdb-4.5.so
--> Processing Dependency: libdb-4.5.so for package: rpm-libs
Quick matched compat-db45-4.5.20-5.fc10.i386 to require for libdb-4.5.so
rpm-devel-4.6.0-0.rc1.3.i386 requires: libdb-4.5.so
--> Processing Dependency: libdb-4.5.so for package: rpm-devel
Quick matched compat-db45-4.5.20-5.fc10.i386 to require for libdb-4.5.so
---> Package compat-db46.i386 0:4.6.21-5.fc10 set to be updated
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
--> Running transaction check
---> Package rpm-libs.i386 0:4.6.0-0.rc1.5 set to be updated
---> Package rpm.i386 0:4.6.0-0.rc1.5 set to be updated
---> Package compat-db45.i386 0:4.5.20-5.fc10 set to be updated
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
rpm-python-4.6.0-0.rc1.3.i386 requires: rpm = 4.6.0-0.rc1.3
--> Processing Dependency: rpm = 4.6.0-0.rc1.3 for package: rpm-python
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
---> Package rpm-build.i386 0:4.6.0-0.rc1.5 set to be updated
---> Package rpm-devel.i386 0:4.6.0-0.rc1.5 set to be updated
--> Running transaction check
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
cyrus-sasl-lib-2.1.22-18.fc10.i386 requires: libdb-4.3.so
--> Processing Dependency: libdb-4.3.so for package: cyrus-sasl-lib
Searching pkgSack for dep: libdb-4.3.so
---> Package rpm-python.i386 0:4.6.0-0.rc1.5 set to be updated
--> Finished Dependency Resolution
Dependency Process ending
cyrus-sasl-lib-2.1.22-18.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libdb-4.3.so is needed by package cyrus-sasl-lib-2.1.22-18.fc10.i386 (installed)
Depsolve time: 7.183
Error: Missing Dependency: libdb-4.3.so is needed by package cyrus-sasl-lib-2.1.22-18.fc10.i386 (installed)
[root@localhost ~]#

Comment 11 Tim Lauridsen 2008-10-31 12:11:29 UTC
ok, i have created a test case to reproduce this problem.

please try this:

make a backup of:

/usr/lib/python2.5/site-packages/yum/__init__.py

and release it with this one.

http://yum.baseurl.org/gitweb?p=yum.git;a=blob_plain;f=yum/__init__.py;hb=yum-3_2_X

Comment 12 Andy Lawrence 2008-10-31 15:46:49 UTC
Created attachment 322098 [details]
test output

Well, not sure?  It completed without actually doing anything!

Comment 13 Andy Lawrence 2008-10-31 15:48:51 UTC
Wait a min, I think that is exactly what is was supposed to do!

Tim, looks like you may have fixed it!

Comment 14 Tim Lauridsen 2008-10-31 16:12:52 UTC
I was to supposed to skip all the packages :)
 
But it look like, there is some problem with the final output
                                                                 
Replaced:
   compat-db.....

should not have been there, but the skip-broken part is ok now.

Comment 15 Tim Lauridsen 2008-11-01 12:10:42 UTC
Andy, could you please retest with this one

http://yum.baseurl.org/gitweb?p=yum.git;a=blob_plain;f=yum/__init__.py;hb=yum-3_2_X

and added the -d7 option and attach the output, to see if i have eliminated the
the 'replaced:' output

Comment 16 Andy Lawrence 2008-11-01 12:23:19 UTC
Created attachment 322170 [details]
More debug

Sure thing, here you go!

Comment 17 Tim Lauridsen 2008-11-01 13:12:50 UTC
Thanks, could you do #15, one more time

Comment 18 Andy Lawrence 2008-11-01 20:51:03 UTC
Created attachment 322183 [details]
Debug #3

Sorry for the size of the output, caught a bunch of updates this round!

Same as #15.

Comment 19 Andy Lawrence 2008-11-02 12:13:13 UTC
Created attachment 322226 [details]
debug #4

New output file without all of the updates.

Comment 20 Tim Lauridsen 2008-11-09 12:08:54 UTC
Could you please recheck with the latest

http://yum.baseurl.org/gitweb?p=yum.git;a=blob_plain;f=yum/__init__.py;hb=yum-3_2_X

and paste the output (-d7)

to see if the latest changes, have changed the wierdness.

Comment 21 Andy Lawrence 2008-11-09 12:53:48 UTC
Thank Tim, but I blasted that box to test the Preview release!  So far haven't seen it again.

Comment 22 Tim Lauridsen 2008-11-09 14:17:32 UTC
Thanks for testing :)

Comment 23 Fedora Update System 2009-01-12 19:19:49 UTC
yum-3.2.21-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc10

Comment 24 Fedora Update System 2009-01-12 19:28:03 UTC
yum-3.2.21-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc9

Comment 25 Fedora Update System 2009-02-05 02:18:10 UTC
yum-3.2.21-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2009-02-05 02:25:41 UTC
yum-3.2.21-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.