Bug 468800 - ata softreset failed messages
ata softreset failed messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 00:49 EDT by Sean Middleditch
Modified: 2009-11-15 15:49 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 493319 (view as bug list)
Environment:
Last Closed: 2009-10-10 03:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Soften up the dmesg on SB600 PMP softreset failure recovery (888 bytes, patch)
2009-08-04 22:18 EDT, Shane Huang
no flags Details | Diff

  None (edit)
Description Sean Middleditch 2008-10-28 00:49:27 EDT
During early bootup (just after grub, before Plymouth) I keep getting the following two messages:

ata1: softreset failed (device not ready)
ata3: softreset failed (device not ready)

I'm using an ASRock A780FullDisplayPort motherboard, which is 780G based.  Phenom X4 9550 CPU.  The harddisk on ata1 is a Serial ATA 1.5G drive, and the DVD-RW on ata3 is a Serial ATA 1.5G drive.

These messages are the only thing displayed, as I have the quiet option enabled in the kernel boot line.  I've been getting these messages for months and I've been following Rawhide very closely, so it's not a recent kernel issue at all -- something that's been there for quite a while.

I don't notice any major slowdowns during boot (nothing that I'd notice as horrendously slow, anyways).  Everything works fine.  It's just kind of annoying that I get those two messages on every boot since it's otherwise quiet and seamless.
Comment 1 Lebenskuenstler 2008-11-13 09:45:28 EST
Same here.

I have a GA-MA78GM-SH2 (F3). And a Samsung HD103UJ SATA harddrive.

I have also problems with Suspend but as I guess that are other issues I file a several bugreport.
Comment 2 Orion Poplawski 2008-11-19 18:23:00 EST
Same here - ata1 - Fujitsu Lifebook S6240
Comment 3 Bug Zapper 2008-11-25 23:20:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Alexander 2008-12-09 09:23:24 EST
I have such an error at boot time also.
MB ASUS M3A ata4 Seagate ST3320613AS harddrive.
The dmesg output includes the following lines after boot:

ata4: softreset failed (device not ready)
ata4: failed due to HW bug, retry pmp=0

I am wondering weather it's a problem with my hardware or the kernel.
Comment 5 Sean Middleditch 2008-12-12 22:32:23 EST
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.27.y.git;a=blob;f=drivers/ata/ahci.c;h=2e1a7cb2ed5f91553ef9d2a39326233197eae7bd;hb=HEAD#l1652

That's the line that is the generator of the message.  I don't know what is actually causing it to fail, though.  The driver I am using is pata_atiixp.  The full set of hardware from lspci:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: ASRock Incorporation Device 9602
00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3200 Graphics
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)
Comment 6 Adrian 2008-12-17 03:37:31 EST
I get the same messages:

ata1: softreset failed (device not ready)
ata1: failed due to HW bug, retry pmp=0

ata3: softreset failed (device not ready)
ata3: failed due to HW bug, retry pmp=0

I also don't notice any slowdowns.

Motherboard: Asus M3A78-EMH HDMI
HDD: ATA SAMSUNG HD161HJ
DVD-RW: TSSTcorp CDDVDW SH-S223F

kernel: 2.6.27.7-134.fc10.x86_64
Comment 7 Stefan Jensen 2008-12-30 19:55:49 EST
same for me here, on:

00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE

with kernel:  2.6.27.9-159.fc10.x86_64

best regards
Comment 8 Vladi 2009-04-01 04:03:45 EDT
F10: kernel 2.6.27.19-170.2.35.fc10

F11 Beta

---------------------------------------------------
I get the same messages:

ata1: softreset failed (device not ready)
ata1: failed due to HW bug, retry pmp=0

lspci output:

00:12.0 SATA controller [0106]: 
ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
Subsystem: Giga-byte Technology Device [1458:b005]
Kernel driver in use: ahci
----------------------------------------------------

(?) ahci: Workaround HW bug for SB600/700 SATA controller PMP support
"There is one bug in ATI SATA PMP of SB600 and SB700 old revision, which leads to soft reset failure. This patch can fix the bug."

http://kerneltrap.org/mailarchive/git-commits-head/2008/6/14/2122314
Comment 9 Sean Middleditch 2009-04-23 13:13:55 EDT
fyi, this is still happening on the latest rawhide kernel for me, 2.6.29.1-85.fc11.x86_64.  It is not just a Fedora 10 thing.
Comment 10 miyasuz 2009-05-25 04:45:16 EDT
I have the same problem with Fedora11 preview
Comment 11 Isaac Salgueiro 2009-06-16 16:20:51 EDT
Same problem here with 2.6.29.4-167.fc11.x86_64

00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
Comment 12 Sean Middleditch 2009-07-26 13:30:03 EDT
still occurs with 2.6.31-0.86.rc3.git5.fc12.x86_64
Comment 13 Shane Huang 2009-08-04 22:18:12 EDT
Created attachment 356254 [details]
Soften up the dmesg on SB600 PMP softreset failure recovery
Comment 14 Shane Huang 2009-08-04 22:19:34 EDT
Too strong words led to spurious bug reports: Novell bugzilla #527748,
RedHat bugzilla #468800. This patch is used to soften up the dmesg on
SB600 PMP softreset failure recovery, so as to remove the scariness and
concern from community.

The above patch has been posted to kernel upstream. thanks.
Comment 15 George Petasis 2009-08-05 18:23:32 EDT
I also see this. GA-MA69GM-S2H with bios F6.
Comment 16 Shane Huang 2009-08-05 21:05:13 EDT
The patch in comment #13 has been posted to kernel and accepted.
Comment 17 Vedran Miletić 2009-10-10 03:57:09 EDT
Fix is in rawhide.
Comment 18 Sean Middleditch 2009-10-10 17:28:19 EDT
Can you please clarify which packages should contain the fix?  Because the latest F12 kernel out of Koji (kernel-2.6.31.3-67.fc12.x86_64) still has the issue for me.
Comment 19 Yul Rottmann 2009-10-11 05:00:23 EDT
Is the "fix" that the error message is another one? Is it necessary to display the message at all?

(GRUB is really nice and KMS is really nice and between is still this error message)
Comment 20 Vedran Miletić 2009-10-11 05:11:40 EDT
Yes, oly the message is changed, since it's a hardware bug. It should be like:
ata1: softreset failed (device not ready)
ata1: applying SB600 PMP SRST workaround and retrying

This is the fix upstream which rawhide picked up: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=b6931c1fbaf7fda9ea7f120228a96600d7090049

And it cannot be hidden completely, since this line could mean a serious failure on other chipsets.
Comment 21 Sean Middleditch 2009-10-22 14:43:00 EDT
I don't follow -- the message is apparently specifically for SB600, so how does it have anything to do with other chipsets?
Comment 22 Vedran Miletić 2009-10-22 14:45:00 EDT
SB700 has the same bug. Not sure about SB710 and SB750.
Comment 23 Maximiliano Castanon 2009-11-07 13:41:17 EST
Same issue here,

ata1: softreset failed (device not ready)
ata1: failed due to HW bug, retry pmp=0
ata2: softreset failed (device not ready)
ata2: failed due to HW bug, retry pmp=0

This is a Laptop
Gateway NV5214u

[maximi89@gateway ~]$ uname -a
Linux gateway 2.6.30.9-90.fc11.i686.PAE #1 SMP Sat Oct 17 11:24:32 EDT 2009 i686 athlon i386 GNU/Linux


[maximi89@gateway ~]$ sudo lspci -v -nn -d 1002:4390
[sudo] password for maximi89: 
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] [1002:4390] (prog-if 01 [AHCI 1.0])
	Subsystem: Acer Incorporated [ALI] Device [1025:021a]
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 22
	I/O ports at 8420 [size=8]
	I/O ports at 8414 [size=4]
	I/O ports at 8418 [size=8]
	I/O ports at 8410 [size=4]
	I/O ports at 8400 [size=16]
	Memory at f0207000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [60] Power Management version 2
	Capabilities: [70] SATA HBA <?>
	Kernel driver in use: ahci
Comment 24 Vedran Miletić 2009-11-07 17:11:03 EST
Well, that's normal and nothing to worry about.
Comment 25 Sean Middleditch 2009-11-15 15:22:14 EST
It is something to worry about because it makes the bootup experience look like crap, it is alarming to users who don't have the technical know-how to resolve bugs with the kernel devs, and it's ENTIRELY USELESS.

The message is telling me absolutely nothing that I as a user need to know.  The message is not telling you as a developer anything because it's showing up on my screen, not yours.  If and only if it is an actual bug causing actual problems do you as the developer need to know that log message appeared, and in that case there's no reason it has to show up on my screen instead of just being part of the dmesg log you would ask me to send if I reported a bug.
Comment 26 Vedran Miletić 2009-11-15 15:49:44 EST
I see at least two ways to solve this:
1) change plymouth to not go to shell when above issue gets displayed
2) change kernel to put such error message as a warning

That being said, on my Athlon X2 7850/HD 4770/AMD 770/SB700 system with KMS on above issue doesn't occur at all. I do get:
ata2: softreset failed (device not ready)
ata4: softreset failed (device not ready)
ata3: softreset failed (device not ready)
ata1: softreset failed (device not ready)
in dmesg, but Plymouth runs the entire boot normally.

Considering this, I would conjecture it's fixed in Fedora 12 with KMS on. Not sure about KMS off situation, but Plymouth isn't exactly exciting in this case IMHO.

Note You need to log in before you can comment on or make changes to this bug.