Bug 46882 - Skipped several screens (I think) in text mode upgrade
Summary: Skipped several screens (I think) in text mode upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-01 19:35 UTC by Telsa Gwynne
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 16:16:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2001-07-01 19:35:16 UTC
This may be my fault.
Text mode upgrade (not with 'expert' though) from RH7.0+bits to fairfax.

Upgrade proceeded along lines I expected, then:
I got the swap size screen. Fine.
Then I got the bootloader configuration one.

"A few systems need.." explanation. Is this for
lilo or grub? Nothing indicated whether the upgrade
would move me to grub, so I didn't know what options
it was talking about at all. I had assumed it would
be lilo options because I've seen this screen before.

Pondered relative merits of "Okay" after leaving the
line blank (as I don't have any special options); or "Skip".
I think I made the wrong choice. I picked "Skip", thinking
it meant "Skip special boot options".

That led me to the next screen: "You have not installed a
bootloader" and "This is a bad idea" warnings. "Ok/Back".

I hit Back from here and met with "Bootloader configuration:
where do you want to put the bootloader?" But I had not seen
this screen at all before!

Then it asked me about "Any other partitions to boot?", I
said no, and it stopped asking any more questions and went
to check package dependencies. (See next bug)

After all this "have you got a bootloader at all?" and
saying "whoops, yes, please", it installed grub. It didn't
tell me that anywhere.

Comment 1 Matt Wilson 2001-07-10 03:12:04 UTC
should be better in beta2



Note You need to log in before you can comment on or make changes to this bug.