Bug 468843 - Xdmx renders QT and GTK apps incorrectly
Xdmx renders QT and GTK apps incorrectly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: 7.1
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 07:12 EDT by Rob Garth
Modified: 2014-06-12 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 13:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the redraw problem (529 bytes, patch)
2008-10-28 07:12 EDT, Rob Garth
no flags Details | Diff

  None (edit)
Description Rob Garth 2008-10-28 07:12:16 EDT
Created attachment 321692 [details]
Patch to fix the redraw problem

Description of problem:
Running QT or GTK apps results in fonts, icons and other details either failing to draw or rendering with incorrect colours. Running Xdmx with -norender fixes the problem, but it is very slow and an unacceptable solution.

How reproducible: Every time


Steps to Reproduce:
1. Start xinit on client nodes
2. startx `which gnome-session` -- Xdmx :1 -display host1:0 -display host2:0 +xinerama
3. Many aspects of the windows fail to render.  Firefox has problems too. Happens with KDE and the same apps run under twm.
  
Additional info:
I have included a patch which can be applied to the SRPM and fixes the problem.
Comment 1 Adam Jackson 2013-11-05 13:55:04 EST
The patch isn't correct, but I'm pretty sure the equivalent problem is still present in RHEL7.
Comment 4 Adam Jackson 2014-06-12 13:22:55 EDT
After some digging, it looks like this is the same issue as:

https://bugs.freedesktop.org/show_bug.cgi?id=7555

Which was fixed upstream in the xserver 1.2 branch.  Therefore I believe this issue is resolved in all RHEL6 and RHEL7 X servers.

Note You need to log in before you can comment on or make changes to this bug.