Bug 468871 - packagekit doesn't work with nx?
packagekit doesn't work with nx?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 10:48 EDT by Neal Becker
Modified: 2009-04-25 08:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-25 08:44:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-10-28 10:48:21 EDT
Description of problem:

I've noticed on 2 of my servers, that I usually access via NX (similar to vnc), that packagekit misbehaves badly.  When there are updates, my screen will be littered with _many_ copies of some dialog, telling me that packagekit failed to do something-or-other, some problem getting authorization?

Closing one of these will instantly pop up another!  This will only be solved after I manually update yum, then manually kill each dialog 1 at a time.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-11-06 05:45:51 EST
Can you explain how to reproduce this please? I need to know all the settings and environment you are using.
Comment 2 Neal Becker 2008-11-06 07:00:27 EST
I didn't change any packagekit settings from defaults.  I'm logging in remotely via NX.  When there are updates available, packagekit goes nuts opening many (hundreds) of dialog windows.

I have seen this same thing on 3 different machines - all machines that I use NX to remotely access do this same thing.

What 'settings' do you need to know?
Comment 3 Davide Repetto 2008-11-16 12:08:45 EST
In FC10 rawhide, packagekit simply refuses to function on a remote connection.
It tells you that it's not allowed to run remotely and it logs the following:

** (gpk-application:1976): CRITICAL **: egg_console_kit_is_local: assertion `console->priv->proxy_session != NULL' failed

I understand that this is an intended feature, but I still would like to be able to use it remotely. It comes in handy!

P.S. Kudos Richard for the great work!!! :)
Comment 4 Richard Hughes 2008-11-16 12:47:18 EST
I fixed that a few days ago:

commit 6f4b44e3fda4fe086bdcab24ec88ab411af50a6a
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Nov 3 09:56:52 2008 +0000

    bugfix: don't print a critical warning when we get egg_console_kit_is_local when not on a session
Comment 5 TK009 2009-03-06 19:17:52 EST
I am assigning this because the maintainer has responded. I am a little confused however.

The original reporter set the version as F9 but provided no further details like the version of packagekit causing the problem.

Comment #3, while it looks like a similar problem, seems to have hijacked the original report(F10 rawhide).
Comment 6 Dawid Zamirski 2009-04-22 10:13:27 EDT
rhuges,

I'm running current rawhide now over remote nx and while I can not run gpk-application and permform searches, selecting a package to install and pressing Apply does not do anything - I can see "getting information" an then "resolving dependencies" status messages but after that it comes back to the result list and the installation doesn't continue. I did not see any error messages in /var/log/messages or when starting gpk-application from command line. The only messages I get when startin from command line are:

Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".
Xlib:  extension "Generic Event Extension" missing on display ":2000.0".

but I don't think that they have anything to do with the problem. Of course, when running locally gpk-application does its job very well.
Comment 7 Richard Hughes 2009-04-22 10:16:16 EDT
Have you tried setting the policy in polkit-gnome-authorization?
Comment 8 Dawid Zamirski 2009-04-22 10:25:09 EDT
I've just tried to do that but I cannot grant anything remotely - the Grant button of the Grant Authorization dialog is grayed out. I can see though that eg "Install signed package" permission has "Must be on console" constraint, so I think that's it - just can't verify right now..
Comment 9 Dawid Zamirski 2009-04-23 09:38:10 EDT
Ok, I have changed the policy in the policykit and it works fine now. Thanks.
Comment 10 TK009 2009-04-24 11:36:44 EDT
Should call this one closed then?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Dawid Zamirski 2009-04-24 11:51:55 EDT
TK009,

As far as I'm concerned, it's ok to close.
Comment 12 TK009 2009-04-25 08:44:42 EDT
With no objections.

Closed Current Release.

TK009

Note You need to log in before you can comment on or make changes to this bug.