This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468885 - Fedora 10 snapshot 3 fails to install via NFS
Fedora 10 snapshot 3 fails to install via NFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-10-28 12:38 EDT by Paul Moore
Modified: 2013-01-09 23:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 19:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen capture of failed NFS install (66.29 KB, image/png)
2008-10-28 12:38 EDT, Paul Moore
no flags Details
Screen capture of failed NFS install with a manually created loopback mount (60.85 KB, image/png)
2008-10-28 12:40 EDT, Paul Moore
no flags Details
Anaconda Log (36.19 KB, text/plain)
2008-10-28 14:22 EDT, Paul Moore
no flags Details
Anaconda Log using clumens update from #7 (37.39 KB, text/plain)
2008-10-30 12:33 EDT, Paul Moore
no flags Details
Anaconda Log using clumens update from #9 (36.92 KB, text/plain)
2008-10-30 16:03 EDT, Paul Moore
no flags Details

  None (edit)
Description Paul Moore 2008-10-28 12:38:51 EDT
Created attachment 321707 [details]
Screen capture of failed NFS install

Description of problem:
When installing Fedora 10 snapshot 3 using a NFS repository the install fails with a "metadata error".

Version-Release number of selected component (if applicable):
Fedora 10 snapshot 3

How reproducible:
Everytime

Steps to Reproduce:
1. Try to install Fedora 10 snapshot 3 using a NFS repository
  
Actual results:
See attachment and above description

Expected results:
Working installation

Additional info:
This method of installation has worked for me without problems for multiple Fedora/RHEL releases up to and including F8, I haven't tried F9.
Comment 1 Paul Moore 2008-10-28 12:40:18 EDT
Created attachment 321708 [details]
Screen capture of failed NFS install with a manually created loopback mount

When I tried manually creating a loopback mount on the NFS server for the ISO image I get the following error.
Comment 2 Paul Moore 2008-10-28 12:42:42 EDT
As an FYI, the NFS directory contains the following files:

 * Fedora-10-Snap3-x86_64-DVD.iso
 * install.img
 * images (symlink to '.')
Comment 3 Chris Lumens 2008-10-28 12:56:03 EDT
Can you attach /tmp/anaconda.log to this bug report?
Comment 4 Paul Moore 2008-10-28 14:22:47 EDT
Created attachment 321716 [details]
Anaconda Log

Requested logfile, /tmp/anaconda.log
Comment 5 Chris Lumens 2008-10-28 14:29:05 EDT
Does it work if you pass method=nfsiso:... instead of method=nfs:... ?
Comment 6 Paul Moore 2008-10-28 14:56:29 EDT
When I used "nfsiso" instead of "nfs" the text portion of the installer asks me to pick an install method.
Comment 7 Chris Lumens 2008-10-30 10:49:39 EDT
Okay, does keeping method=nfs: but using updates=http://clumens.fedorapeople.org/468885.img fix things?  The problem here is we're simply never mounting the ISO images.
Comment 8 Paul Moore 2008-10-30 12:33:37 EDT
Created attachment 321958 [details]
Anaconda Log using clumens update from #7

When using the update from comment #7 Anaconda throws an exception and the install has to be aborted.
Comment 9 Chris Lumens 2008-10-30 13:35:42 EDT
Oh, sorry about that - I was mixing up two different methods of fixing this problem.  Could you please retry with the same updates image?
Comment 10 Paul Moore 2008-10-30 16:03:18 EDT
Created attachment 321983 [details]
Anaconda Log using clumens update from #9

Another exception, see the attached log.  Are you guys not able to reproduce this problem locally?  I'm happy to help verify a fix but it seems like I'm doing the unit testing here ...
Comment 11 Chris Lumens 2008-10-31 13:58:48 EDT
Sorry about that, the proper fix should be in the next build of anaconda.
Comment 12 Jesse Keating 2008-11-07 19:04:41 EST
I have verified the above scenario with the latest anaconda (which will hit rawhide tomorrow).  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.