This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468891 - modesetting: xrandr --output XYZ --off doesn't disable output
modesetting: xrandr --output XYZ --off doesn't disable output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 13:11 EDT by Stefan Becker
Modified: 2009-09-12 04:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 04:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (41.97 KB, text/plain)
2009-02-15 13:35 EST, Stefan Becker
no flags Details
X server log (318.82 KB, text/plain)
2009-02-15 13:35 EST, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2008-10-28 13:11:17 EDT
Description of problem:

When the kernel is booted up with KMS enabled then xrandr can't disable outputs. After executing "xrandr --output XYZ --off" the display is still active and gets updated. Only the mouse pointer is no longer visible.

If you boot the kernel with "nomodeset" xrandr works correctly.

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-58.fc10.i686
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-server-Xorg-1.5.2-10.fc10.i386
xorg-x11-drv-ati-6.9.0-34.fc10.i386

How reproducible: Always

Additional info:

$ lspci | fgrep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
$ lspci -n | fgrep 01:00.0
01:00.0 0300: 1002:7149
Comment 1 Bug Zapper 2008-11-25 23:22:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 François Cami 2009-02-14 12:49:54 EST
Stefan,
Could you confirm the bug is still here on current F10 ?
Could you post :
* dmesg
* /var/log/Xorg.0.log 
as uncompressed text attachments to this bug ?
Thank you
Comment 3 Stefan Becker 2009-02-15 13:35:04 EST
Created attachment 331984 [details]
dmesg log

The situation has changed for the current versions:

kernel-2.6.27.12-170.2.5.fc10.i686
xorg-x11-drv-ati-6.10.0-2.fc10.i386

Now xrandr --off disables the output *BUT* permanently! If I connect to my TV via DVI/HDMI, enable that output, disable LVDS then I only see output on the TV. But then when I activate LVDS again it stays blank. Only a reboot brings it back to live. The resolution change seems to work, as the screen size changes, but the CRTC doesn't seem to get enabled.

Xorg.0.log follows
Comment 4 Stefan Becker 2009-02-15 13:35:45 EST
Created attachment 331985 [details]
X server log
Comment 5 Stefan Becker 2009-03-31 13:00:37 EDT
Test system moved to F11 rawhide. Retested with:

kernel-2.6.29-16.fc11.i586
libdrm-2.4.5-3.fc11.i586
xorg-x11-server-Xorg-1.6.0-15.fc11.i586
xorg-x11-drv-ati-6.12.0-2.fc11.i586

"xrandr --output XYZ --off" works correctly now.
Comment 6 François Cami 2009-04-01 16:21:35 EDT
Stefan,

Thanks for testing and making sure rawhide is not affected,
this is greatly appreciated.
Reopening since we need to track the status for F10.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Stefan Becker 2009-09-12 04:20:01 EDT
This will never be fixed for F10. Test system is already moved to F11 and soon F12...

Note You need to log in before you can comment on or make changes to this bug.