Bug 468909 - GCC crash with premature EOF on input during assembler phase
GCC crash with premature EOF on input during assembler phase
Status: CLOSED DUPLICATE of bug 440139
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 15:05 EDT by Mike
Modified: 2008-10-31 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 12:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2008-10-28 15:05:29 EDT
Description of problem:

I am trying to build Wine 1.1.7. I have downloaded the latest source tree
and I am trying to build it.
gcc crashes with premature EOF whilst compiling ~/wine/dlls/user32/tests/menu.c


Version-Release number of selected component (if applicable):

gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)

How reproducible:

Every time 100%

Steps to Reproduce:
1. Download the latest Wine (1.1.7) source tree 
2. Try building it.
3. 
  
Actual results:

gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7408: Warning: end of file not at end of a line; newline inserted
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.


Expected results:

Err, I expect it to compile, and not bomb out ?!

Additional info:
Comment 1 Mike 2008-10-29 13:47:14 EDT
Remove the -pipe and -O2 options and it compiles OK
Comment 2 Jakub Jelinek 2008-10-31 12:54:42 EDT

*** This bug has been marked as a duplicate of bug 440139 ***

Note You need to log in before you can comment on or make changes to this bug.