This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468914 - crash of system-config-network
crash of system-config-network
Status: CLOSED DUPLICATE of bug 468355
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 15:35 EDT by Edwin Schepers
Modified: 2008-10-29 08:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 08:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edwin Schepers 2008-10-28 15:35:58 EDT
Description of problem:
crash when starting system-config-network.
( I started from the commandline)

This happens now after I updated all packages.

How reproducible:


Steps to Reproduce:
1. just start it

Additional info:
Component: system-config-network
Version: 1.5.10
Summary: TB24531662 NCBackendHal.py:103:getDevices:TypeError: not enough arguments for format string

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 275, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 300, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 312, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 759, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 603, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 483, in updateFromSystem
    self.updateFromHal(hdellist)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 448, in updateFromHal
    cards = hal.probeCards()
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 124, in probeCards
    card = self.getDevices(udi)
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 103, in getDevices
    hw.Description = "%s %s" % self.getVendor(udi)
TypeError: not enough arguments for format string

Local variables in innermost frame:
category: net
obj: <ProxyObject wrapping <dbus._dbus.SystemBus (system) at 0x1d681d0> :1.0 /org/freedesktop/Hal/devices/net_66_fe_ec_3b_2b_c6 at 0x1d7a1d0>
name: virbr0
arp_proto_hw_id: 1
hwf: {'Wireless': {0: <class netconfpkg.plugins.NCHWWireless.HwWireless at 0x15620b0>}, 'Ethernet': {0: <class netconfpkg.plugins.NCHWEthernet.HwEthernet at 0x1540d10>}, 'Modem': {0: <class netconfpkg.plugins.NCHWModem.HwModem at 0x1540e30>}, 'ISDN': {0: <class netconfpkg.plugins.NCHWIsdn.HwIsdn at 0x1540dd0>}, 'Token Ring': {0: <class netconfpkg.plugins.NCHWTokenring.HwTokenring at 0x1540fb0>}}
self: <netconfpkg.NCBackendHal.NCBackendHal instance at 0x1d74200>
hw: Hardware.Status=inactief
Hardware.Name=virbr0
Hardware.Type=Ethernet

hwc: netconfpkg.plugins.NCHWEthernet.HwEthernet
htype: Ethernet
udi: /org/freedesktop/Hal/devices/net_66_fe_ec_3b_2b_c6
getHardwareFactory: <function getHardwareFactory at 0x1558c08>
Comment 1 Harald Hoyer 2008-10-29 08:26:53 EDT

*** This bug has been marked as a duplicate of bug 468355 ***

Note You need to log in before you can comment on or make changes to this bug.