Bug 468935 - "Print to file" on first-use sometimes really prints to the default printer
"Print to file" on first-use sometimes really prints to the default printer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-28 18:57 EDT by Bill Nottingham
Modified: 2014-03-16 23:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 10:02:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-10-28 18:57:30 EDT
Description of problem:

I select 'Print to file', and choose to print.

It prints to the default printer (i.e., not to a file.)

I then select 'Print to file', and choose to print.

It then prints to a file.

Version-Release number of selected component (if applicable):

openoffice.org-core-3.0.0-9.6.fc10.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Print to file
  
Actual results:

Prints somewhere else (the first time). 

Expected results:

Prints to file.
Comment 1 Caolan McNamara 2008-10-28 19:12:15 EDT
Err..., that's odd and I don't see it myself. 

Is it opening an existing document and using print to file, or writing a new one from scratch. What OOo application, writer or calc or something else ?. Is it when not changing any defaults, i.e. just taking "output.pdf" format "pdf", or twiddling to .ps ?

Maybe there is a race in here wrt. printer detection and using any print functionality.
Comment 2 Bill Nottingham 2008-10-28 21:16:22 EDT
I reproduced this again.

Open document. (Existing document, ooffice <file> Opened in writer.)

Select 'print'. It defaults to my default pritner.

Pick a browsed printer. Final '<print>' button is greyed out. Not sure why.

Select 'Print to file'. Flip it to PS output.

... sent to default printer.

I then tried for more reproductions, and it didn't happen. So, maybe there is a race somewhere.
Comment 3 Caolan McNamara 2008-10-29 05:20:55 EDT
Yeah, I have it. Printer detection hasn't truly finished, so we force it to complete and wait, but the side-effect is that the current "print to file" setting gets tossed out so we end up printing to the default printer. We just need to move setting those properties to after we have the final printer handle.


(Pick a browsed printer. Final '<print>' button is greyed out. Not sure why.)

FWIW, that'd be the dialog itself, not OOo so I'd expect evince (and other users of that dialog) to show the same greyed out button for a printer if OOo shows one. Might be greyed out while waiting for some cups querying of capabilities or something)
Comment 4 Matthias Clasen 2008-10-29 14:54:54 EDT
Marek, can you have a look at this.

Maybe this broke during our latest async changes for default printer handling ?
Comment 5 Caolan McNamara 2008-10-29 18:56:33 EDT
Err.., hang on here. I'm pretty sure the substantive issue is my one and OOo specific.

There may be some generic issue wrt. the greyed out button sceál but the primary info coming from the dialog as to "print to file" being selected is good from gtk2-print-unix
Comment 6 Marek Kašík 2008-11-03 11:44:52 EST
I reproduced the problem with gtk older than the one in which the default printer handling is changed. So it is not broken by this change.
I reproduced this for printing to PostScript file only and only for documents opened from a disc (not for new documents). It works for PDF for me. So it is probably bug in OOo.
I couldn't reproduce the problem with the greyed out button. Does it show up with "gtk-demo" (the Printing section)?

  Marek
Comment 7 Caolan McNamara 2008-11-03 11:50:53 EST
"So it is probably bug in OOo.". Yes, see #3.
Comment 8 Jesse Keating 2008-11-14 13:12:26 EST
Caolan, why did this get closed?  Was there a new oo.org build to fix it, and if so, has it been tagged for the final release?
Comment 9 Bill Nottingham 2008-11-14 13:46:04 EST
This was fixed in 3.0.0-9.7. F10 currently has 3.0.0-9.10.

Note You need to log in before you can comment on or make changes to this bug.