Bug 468943 - radeonhd-20081014git finds wrong BIOS for secondary card
radeonhd-20081014git finds wrong BIOS for secondary card
Status: CLOSED DUPLICATE of bug 505679
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 21:36 EDT by Wayne Whitney
Modified: 2009-09-06 12:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 12:36:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.log file for radeonhd BIOS misdetection (16.22 KB, text/plain)
2008-10-28 21:36 EDT, Wayne Whitney
no flags Details

  None (edit)
Description Wayne Whitney 2008-10-28 21:36:30 EDT
Created attachment 321736 [details]
Xorg.log file for radeonhd BIOS misdetection

I have an x86_64 system with two Radeon GPUs, an HD 3200 (RS780) on the motherboard plus a PCIe HD 2600XT (RV630), and I would like to run multicard multiseat.  In the motherboard BIOS I have "SurroundView" enabled, which makes the PCIe card primary but still allocates UMA for the motherboard GPU.  X runs fine on the primary card.  When I try to run X on the secondary GPU with IsolateDevice, it incorrectly uses the BIOS information of the primary card:

(II) RADEONHD(0): Getting BIOS copy from legacy VBIOS location
(II) RADEONHD(0): ATOM BIOS Rom: 
        SubsystemVendorID: 0x1462 SubsystemID: 0x0990
        IOBaseAddress: 0xd000
        Filename: SV26218.bin 
        BIOS Bootup Message: 
113-MSITV099MS.211 RV630XT HYNIX 32MX16 256MB DUAL DVII+TVO       

This is the information from the primary card, the RV630.  As a result it soon fails with "Failed to detect a connected monitor".  This occurs with the latest rawhide RPM, xorg-x11-drv-radeonhd-1.2.3-1.2.20081014git.fc10.x86_64.  I've attached the full Xorg.log file.

As a side note, if I disable SurroundView on the motherboard and make the onboard GPU primary, then when I try to run X on the secondary card, it fails to find the secondary BIOS at all:

(II) RADEONHD(0): Getting BIOS copy from PCI ROM
(EE) RADEONHD(0): rhdAtomGetTables: No AtomBios signature found
Comment 1 Bug Zapper 2008-11-25 23:23:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Vedran Miletić 2009-09-06 03:00:46 EDT
Reporter, is this still an issue? Does it work with xorg-x11-drv-ati?
Comment 3 Wayne Whitney 2009-09-06 12:36:20 EDT
Subsequent investigation led me to the conclusion that the problem is in xorg-x11-server and the way it handles primary card detection when IsolateDevice is in use.  I have filed a separate bug on that in June, Bug 505679, although it is still status NEW and hasn't been assigned.  

So I am closing this bug and marking it as a duplicate of Bug 505679.  I hope that is the correct administrative dispensation for this bug.

Cheers, Wayne

*** This bug has been marked as a duplicate of bug 505679 ***

Note You need to log in before you can comment on or make changes to this bug.