Bug 468952 - Cannot connect to pptp vpn, selinux is blocking operations
Cannot connect to pptp vpn, selinux is blocking operations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 23:32 EDT by Craig Robson
Modified: 2008-10-29 10:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Robson 2008-10-28 23:32:18 EDT
Description of problem:

I get the following selinux warning when attempting to connect to a PPTP VPN.

SELinux is preventing sh (pptp_t) "execute" to ./ip (ifconfig_exec_t).
SELinux is preventing sh (pptp_t) "getattr" to /sbin/ip (ifconfig_exec_t).

Version-Release number of selected component (if applicable):
NetworkManager-pptp-0.7.0-0.11.svn4229.fc10.i386

How reproducible:
Fails every time.

Steps to Reproduce:
Create PPTP configuration in NetworkManager.
Attempt to connect to VPN with it.
  
Additional info:

Raw Audit Messages            

node=pip.zhatt.com type=AVC msg=audit(1225250105.213:16): avc:  denied  { execut
e } for  pid=3280 comm="sh" name="ip" dev=sda3 ino=202882 scontext=system_u:syst
em_r:pptp_t:s0 tcontext=system_u:object_r:ifconfig_exec_t:s0 tclass=file

node=pip.zhatt.com type=SYSCALL msg=audit(1225250105.213:16): arch=40000003 sysc
all=11 success=no exit=-13 a0=8d85130 a1=8d85150 a2=8d843a8 a3=0 items=0 ppid=32
78 pid=3280 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgi
d=0 tty=(none) ses=4294967295 comm="sh" exe="/bin/bash" subj=system_u:system_r:p
ptp_t:s0 key=(null)

Raw Audit Messages            

node=pip.zhatt.com type=AVC msg=audit(1225250105.213:18): avc:  denied  { getatt
r } for  pid=3280 comm="sh" path="/sbin/ip" dev=sda3 ino=202882 scontext=system_
u:system_r:pptp_t:s0 tcontext=system_u:object_r:ifconfig_exec_t:s0 tclass=file

node=pip.zhatt.com type=SYSCALL msg=audit(1225250105.213:18): arch=40000003 sysc
all=195 success=no exit=-13 a0=8d85130 a1=bfa23b70 a2=2c0ff4 a3=8d85130 items=0 
ppid=3278 pid=3280 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid
=0 fsgid=0 tty=(none) ses=4294967295 comm="sh" exe="/bin/bash" subj=system_u:sys
tem_r:pptp_t:s0 key=(null)
Comment 1 Dan Williams 2008-10-28 23:53:40 EDT
Dan, I'm pretty sure it's not NM calling /sbin/ip here, could be something internal to PPP or PPTP.  Can we track this down further somehow to a specific process that's exec-ing /sbin/sh?
Comment 2 Daniel Walsh 2008-10-29 10:49:14 EDT
Looks like a typo in policy.

Fixed in selinux-policy-3.5.13-10..fc10

Also fixing in F8,f9, and RHEL5

Note You need to log in before you can comment on or make changes to this bug.