This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468953 - HAL mounts volumes while working with GParted
HAL mounts volumes while working with GParted
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 00:27 EDT by Ben Gamari
Modified: 2009-02-24 16:03 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.4.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 16:03:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 37768 None None None Never

  None (edit)
Description Ben Gamari 2008-10-29 00:27:10 EDT
Description of problem:
Attempting to alter the partition table with GParted causes the kernel to re-read the partition table which in turn prompts HAL to mount any readable volumes, interrupting GParted. This is especially dangerous when attempting to resize a partition and generally renders gparted useless. See the Launchpad bug for more details


Version-Release number of selected component (if applicable):
gparted.x86_64-0.3.9-1.fc10.1

How reproducible:
Always.
Comment 1 Deji Akingunola 2008-10-29 01:02:20 EDT
Did you really noticed this issue on your Fedora installation, or you just want to bring the Launchpad bug to attention? The bug you referred to was resolved as been fixed upstream in gparted-0.3.8, and the Fedora version you are filing against is gparted-0.3.9.
Comment 2 Ben Gamari 2008-10-29 01:07:48 EDT
It just happened to me while trying to repartition my external harddrive on Rawhide.
Comment 3 Deji Akingunola 2008-10-29 01:36:56 EDT
Hal Maintainer(s),

This seems to be an issue with hal-lock; gparted is executed by running a script which do 'hal-lock --interface org.freedeskdesktop.Hal.Device.Storage --exclusive --run "/usr/sbin/gpartedbin $*"'
Comment 4 Bug Zapper 2008-11-25 23:24:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Colignon Michael 2008-11-27 20:52:33 EST
Hello, i use fedora 10 and this bug are always present.
hal(autofs??) try mount when formatting step is beginning

result:partition are corrupted

sorry for my poorly english.

Michael C.
Comment 6 Ed Swierk 2008-12-22 17:32:05 EST
I work around this bug by running

  gconftool-2 -s -t bool /apps/nautilus/preferences/media_automount false

to disable automatic media mounting (see bug 476586).
Comment 7 Fedora Update System 2009-02-24 15:52:55 EST
gparted-0.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-02-24 16:03:11 EST
gparted-0.4.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.