Bug 468956 - on shutdown, stopping anacron fails
on shutdown, stopping anacron fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 01:26 EDT by Andre Robatino
Modified: 2008-10-29 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 09:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2008-10-29 01:26:47 EDT
Description of problem:
If one uses Alt-F7 to see the shutdown messages (unfortunately they don't show by default due to bug #439699), there are two "Stopping anacron" messages.  The second one always fails, the first may or may not fail.

Version-Release number of selected component (if applicable):
anacron-2.3-61.fc9.i386

How reproducible:
always

Steps to Reproduce:
1.  Shutdown and use Alt-F7 to see shutdown messages.

Additional info:
I don't remember when this started but it was probably within the last month or two.  Sorry I can't be more specific.  I've seen this in two F9 fully updated clean installs, one running in VirtualBox with a Windows XP host.
Comment 1 Marcela Mašláňová 2008-10-29 05:53:35 EDT
Please try anacron-2.3-62.fc9 and let me know.
Comment 2 Andre Robatino 2008-10-29 06:15:23 EDT
With anacron-2.3-62.fc9, there are no "stopping anacron" messages at all. I checked System/Administration/Services and anacron is enabled but stopped.  Is this all normal default behavior?  I never made any anacron-related changes manually.
Comment 3 Marcela Mašláňová 2008-10-29 09:42:20 EDT
Yes, that's intended behaviour. This daemon lives only as long as its has something to do, then stopped itself. Usually it runs yours cron.daily jobs after switching on your computer (with some delay) once a day.

I was interested in problem with "double stopping". So it looks like this problem was fixed. Please feel free to reopen it, if your problem persist.

Note You need to log in before you can comment on or make changes to this bug.