Bug 468969 - Assertion 'i->thread_info.rewrite_nbytes == 0' failed when switching VT
Assertion 'i->thread_info.rewrite_nbytes == 0' failed when switching VT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 05:31 EDT by Mads Kiilerich
Modified: 2008-11-11 05:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 05:10:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulse messages, truncated in the middle (24.53 KB, text/plain)
2008-10-29 05:31 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2008-10-29 05:31:27 EDT
Created attachment 321769 [details]
pulse messages, truncated in the middle

Description of problem:

It generally works fine that sound stops and resumes when I switch user / virtual terminals.

But once when I switched I got 
sink-input.c: Assertion 'i->thread_info.rewrite_nbytes == 0' failed at pulsecore/sink-input.c:1150, function pa_sink_input_request_rewind(). Aborting.

That killed pulseaudio and left pidgin and rhythmbox hanging. (Even though it would be nice if nothing killed pulse, it would also be nice if a dying pulse was handled somehow and the client apps didn't hang...)

As described on bug 462200#c67 I am quite happy with pulseaudio now on my
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02) with snd_hda_intel
and I _don't_ consider this a "Various issues causing PA to be killed by the CPU load limiter" instance.


Version-Release number of selected component (if applicable):

kernel-2.6.27.4-58.fc10.i686
pulseaudio-0.9.13-4.fc10.i386


How reproducible:

Only seen once, and usually there is no problem.


Steps to Reproduce:

1. Music playing
2. Ctrl-Alt-Fn
Comment 1 Mads Kiilerich 2008-11-11 05:10:13 EST
I can't reproduce this. Closing.

Note You need to log in before you can comment on or make changes to this bug.