Bug 46899 - Bitmaps distorded and/or destroyed in XFree86 using GNOME and KDE
Bitmaps distorded and/or destroyed in XFree86 using GNOME and KDE
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 18:27 EDT by Chet Simpson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 16:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chet Simpson 2001-07-01 18:27:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When using a Creative GRaphics Blaster Exxtreme, the Bitmaps/Graphics seem
to get distorted or get destroyed almost immediately after starting an
application.  At first I thought this might be an alignment problem in the
driver but now it appears that once the graphic buffer for the bitmap is
initialized it is getting overwritten with information from other draw/blit
operations.  Another side problem is that when running in 16bit mode, the
color information seems to be reversed giving a psychedelic look to the
display.

Aside from that, XFree86 does seems to work properly in 256 color more.


System information:
	RedHat 7.1 (iso images downloaded 7/1/2001)
	550mhz Pentium III
	384mb RAM
	Creative Labs Graphics Blaster Exxtreme 4mb

How reproducible:
Always

Steps to Reproduce:
1. Set XFree86 to use the Permedia II 2d+3d glint drivers running at
1024x768x24 or 1024x768x16
2.Start XFree86 with either GNOME or KDE as the desktop
3.Start any application (web browsers are best for this one)
4.Move the window around, shrink it, expand it, etc.
5.Notice the graphics get hosed
6.Go have some coffee - job well done!

	

Actual Results:  Graphics become garbage

Expected Results:  Graphics should not become garbage :)

Additional info:
Comment 1 Mike A. Harris 2001-08-26 19:16:42 EDT
Many bugs have been fixed in permedia support since 7.1 was released.
The updated packages of 4.0.3 are available from:
ftp://people.redhat.com/mharris/testing/7.1

An official errata release of 4.1.0 will be made in the near future.

Note You need to log in before you can comment on or make changes to this bug.