This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468991 - Application 'libcanberra-login-sound.desktop' failed to register before timeout
Application 'libcanberra-login-sound.desktop' failed to register before timeout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 07:57 EDT by Ralf Corsepius
Modified: 2008-12-19 08:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 09:12:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-10-29 07:57:45 EDT
Description of problem:
After each login from gdm, I find this kind of warning message in /var/log/message:

Oct 29 12:51:12 gunvald gnome-session[23388]: WARNING: Application 'libcanberra-login-sound.desktop' failed to register before timeout

Version-Release number of selected component (if applicable):
gnome-session-2.24.1-3.fc10.i386
libcanberra-0.10-2.fc10.i386
on an uptodate (2008-10-29) rawhide system.

How reproducible:
Deterministic

Steps to Reproduce:
1. boot into runlevel 5
2. login into normal users via gdm
3. Look into /var/log/messages
  
Actual results:
Warning being raised

Additional info:
I have no idea if this is a gnome-session or a libcanberra issue, or might be related to some upgrading issue (The system originally was an FC10-Beta1 system and supsequently followed rawhide)
Comment 1 Lennart Poettering 2008-10-30 22:11:41 EDT
Sounds like a gnome-session issue to me.
Comment 2 Mads Kiilerich 2008-11-11 20:04:56 EST
This is a duplicate of Bug 467206 which has been closed wont-fix-ish.

But it really should be fixed...
Comment 3 Ray Strode [halfline] 2008-11-18 16:29:21 EST
Hi,

libcanberra-login-sound currently has this in its desktop file:

X-GNOME-Autostart-Phase=Desktop

Which is the phase used for nautilus.  Apps started in that phase are required to register with the session manager.  

See http://live.gnome.org/SessionManagement/GnomeSession

Really, we'd want some sort of way to register to run in the edge between phase transitions, but failing that feature, I'd recommend just changing the Phase to Application

moving back to libcanberra
Comment 4 Bug Zapper 2008-11-25 23:25:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Lennart Poettering 2008-12-18 09:12:08 EST
This has been fixed in 0.10-3.
Comment 6 Ralf Corsepius 2008-12-19 03:57:09 EST
Though I don't understand why you closed this bug (There is no FC10 update available in CURRENTRELEASE), I can confirm libcanberra-0.10-3 appears to have fixed the issue.
Comment 7 Lennart Poettering 2008-12-19 08:02:19 EST
Oh, I wasn't aware that the new lc rpms are still stuck in bodhi. Make sure to add some positive feedback to lc in bodhi because otherwise lc won't ever move to FC10 stable.

Note You need to log in before you can comment on or make changes to this bug.