Bug 469022 - Xguest default profile cannot be modified by sabayon
Xguest default profile cannot be modified by sabayon
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sabayon (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 10:49 EDT by Joachim Katzer
Modified: 2015-03-03 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 15:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sabayon log file (1.38 KB, text/plain)
2008-10-29 10:49 EDT, Joachim Katzer
no flags Details

  None (edit)
Description Joachim Katzer 2008-10-29 10:49:21 EDT
Created attachment 321812 [details]
Sabayon log file

Description of problem:
Modification of Xguest default profile /etc/desktop-profiles/xguest.zip made by sabayon cannot be saved. 

Version-Release number of selected component (if applicable):
Fedora-9 i386 with GNOME desktop, all released patches installed
xguest-1.0.6-7.fc9.noarch
sabayon-2.22.0-4.fc9.i386
libxcb-1.1-5.fc9.i386 or later (currently from fedora-testing repo)


How reproducible:


Steps to Reproduce:
1. Start sabayon and open xguest.zip
2. Do some changes in Xnest window
3. Save 
  
Actual results:
After closing Xnest window, Sabayon reports error message and logs errors to attached log file.

Expected results:
Modification should be saved to /etc/desktop-profiles/xguest.zip


Additional info:
It is possible to create a new profile and rename it to xguest.zip. This can be saved and applied when logging in as xguest! Therefore I suppose xguest.zip installed by xguest RPM is not compatible with current sabayon version.

In default xguest profile, xscreensaver is activated and configured to lock the screen. When this happens (after 10 minutes of no activity), the screen cannot be unlocked by user!
Comment 1 Daniel Walsh 2008-10-29 12:07:07 EDT
This is not an xguest bug but a sabayon one.

Does screen lock have pam_sepermit in it?
Comment 2 Daniel Walsh 2008-10-29 12:08:15 EDT
# cat /etc/pam.d/gnome-screensaver 
#%PAM-1.0

# Fedora Core
auth     [success=done ignore=ignore default=bad] pam_selinux_permit.so
session    include	system-auth
auth       include	system-auth
auth       optional     pam_gnome_keyring.so
account    include	system-auth
password   include	system-auth

# SuSE/Novell
#auth       include      common-auth
#account    include      common-account
#password   include      common-password
#session    include      common-session
Comment 3 Joachim Katzer 2008-10-30 15:18:17 EDT
Sorry, I cannot reproduce the screen lock problem on F9 with a GNOME desktop anymore.

It may happen with XFCE deskop, but this is now clear for me because file /etc/pam.d/xscreensaver does not contain the pam_selinux_permit.so line.
Comment 4 Daniel Walsh 2008-10-30 15:47:32 EDT
Ok Closing for now as worksforme.

Note You need to log in before you can comment on or make changes to this bug.