Bug 469029 - errata.bugzilla_fixes returns keys in the map as a string, not an int
errata.bugzilla_fixes returns keys in the map as a string, not an int
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Dobies
wes hayutin
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2008-10-29 11:32 EDT by Justin Sherrill
Modified: 2009-09-10 15:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:53:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-10-29 11:32:57 EDT
errata.bugzilla_fixes returns a map:

id -> summary

and documents id as an int.  It is a string however.

Since this call has been around for a while, I say just change the docs.
Comment 1 Jay Dobies 2009-02-16 15:03:14 EST
Commit: 1f5918c5851a341251ce7bf237fddec90815b796

ErrataHandler.java
- Despite the fact that the bug ID is a long, XMLRPC treats it as a string when it is the key for a map, so I updated the documentation to reflect that.
Comment 2 wes hayutin 2009-03-09 15:16:00 EDT
	    Map<String,String> errataresult = (Map<String,String>) client.execute("errata.bugzilla_fixes", securityToken, Config.getErrataAdvisory());
	    	Set<String> ids = errataresult.keySet();
	    	assertNotEmpty(ids);
	    	for (String id : ids) {
	    		assertTrue(errataresult.get(id) instanceof String);
	    	}
	    	
pass
proxy.version=5.1
client for 'http://grandprix.rhndev.redhat.com/rpc/api' - created
logged in (admin/dog8code), token: '301x80dc589d7c510f95fdf845882461be56


 Method: bugzillaFixes
Description:
Get the Bugzilla fixes for an erratum matching the given advisoryName. The bugs will be returned in a struct where the bug id is the key. i.e. 208144="errata.bugzillaFixes Method Returns different results than docs say"

Parameters:

    * string sessionKey
    * string advisoryName

Returns:

    * struct - Bugzilla info
          o string "bugzilla_id" - actual bug number is the key into the struct
          o string "bug_summary" - summary who's key is the bug id
Comment 3 Steve Salevan 2009-08-14 16:37:12 EDT
RELEASE_PENDING from latest Stage build.
Comment 4 Brandon Perkins 2009-09-10 15:53:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.