Bug 469047 - Please update intel/i810 X.org driver
Please update intel/i810 X.org driver
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 13:21 EDT by Janne Blomqvist
Modified: 2012-04-17 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 15:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janne Blomqvist 2008-10-29 13:21:04 EDT
Description of problem:

The driver for intel integrated graphics in RHEL 5.x does not support 32-bit colors (?) with DRI and (at least) Q35 chipset, most OpenGL applications work fine but the error message

libGL warning: 3D driver claims to not support visual 0x5b

is printed on the console. However, at least MATLAB R2008a does not work properly. Consider the .m file below:

function testmesh

% if interval >= 1.0 plot works
% if interval <= 0.5 does not work
interval = 0.5;

[X,Y] = meshgrid(1:interval:10, 1:interval:10);

Z = sin(X/3).*Y - X;

mesh(X,Y,Z);

If the interval variable is modified so that it's > 0.5, the above function works correctly, but for interval <= 0.5, the plot area in the window remains empty.

I have tried this with both

       Driver      "i810"

and

       Driver      "intel"

in xorg.conf. Both drivers have the same problem.

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-9.13.el5

I haven't tested xorg-x11-drv-i810-1.6.5-9.18.el5 in RHEL 5.3 beta, but based on the version number I suspect it's not any big change.

AFAICT it seems this problem has been fixed in newer versions of the intel/i810 driver, so it would be nice if the driver in RHEL 5.3 could be rebased to a working version.
Comment 1 Simon B 2009-04-03 12:23:32 EDT
I'd like to add my vote to this, and some additional info.
There seems to have been a regression (in the mesa driver?), since RH4.x machines are working, but 5.x machines do not. for example

[X,Y,Z]=peaks(30);
surf(X,Y,Z);

does not work (produces a blank image)

It currently only works for small number of points e.g. 
[X,Y,Z]=peaks(5);
surf(X,Y,Z);

The glxinfo command produces the 
libGL warning: 3D driver claims to not support visual 0x5b
error on the 5.x machines.

The result of this is that 5.x users are required to use software rendering instead of direct hardware rendering. I am required to keep the users on RH4.x until this is fixed, therefore is a show stopper for me. I believe this is also causing crashes on IDL software too.
Hardware is Intel 82945G/GZ Integrated graphics

running glxinfo on 5.3 gives
0x5b 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
which does not appear on 4.x, however this may not be related to the matlab regression.
Comment 2 Alan Brown 2011-01-21 06:26:42 EST
The crashes on IDL software can be mitigated by switching to software rendering and IDL produced updates in the meantime to try and work around the fault, but the driver definitely needs rebasing as it has a regression:


The current EL5 driver also causes X to crash on the Q35 chipset when using Firefox on specific web pages. The Q35 boards themselves are RH hardware certified. Other (older and newer) Intel chipsets are not affected.


https://hardware.redhat.com/show.cgi?id=383961
https://hardware.redhat.com/show.cgi?id=383941


Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80d1bb1]
1: [0xb64420]
2: /usr/lib/xorg/modules/libfb.so(fbCopyAreammx+0x21e) [0xf6b6ae]
3: /usr/lib/xorg/modules/libfb.so(fbCompositeCopyAreammx+0x66) [0xf6b776]
4: /usr/lib/xorg/modules/libfb.so(fbComposite+0x57b) [0xf5c4fb]
5: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x1db) [0x556eeb]
6: /usr/lib/xorg/modules/drivers/intel_drv.so(i830_xaa_composite+0x148) [0x211da8]
7: /usr/bin/X [0x816aa46]
8: /usr/bin/X [0x81673b6]
9: /usr/bin/X(CompositePicture+0x153) [0x8154503]
10: /usr/bin/X [0x815a34f]
11: /usr/bin/X [0x81576c5]
12: /usr/bin/X(Dispatch+0x19a) [0x80894fa]
13: /usr/bin/X(main+0x485) [0x8070755]
14: /lib/libc.so.6(__libc_start_main+0xdc) [0x2c1e9c]
15: /usr/bin/X(FontFileCompleteXLFD+0x1fd) [0x806fa51]

Fatal server error:
Caught signal 11. Server aborting
Comment 3 Alan Brown 2011-01-21 06:31:39 EST
Note that https://access.redhat.com/kb/docs/DOC-7722 discusses X panicing on exit in Xen kernels with more than 2Gb ram installed and claimed the issue is fixed.

The issue noted in comment 2 is with 4-8Gb 32bit PAE kernels and happens in mid-session.
Comment 4 Adam Jackson 2012-04-17 15:41:53 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  Please use RHEL6 for up-to-date intel graphics support.

Note You need to log in before you can comment on or make changes to this bug.