Bug 469050 - rc script returns non-zero exit code
rc script returns non-zero exit code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 13:39 EDT by Orion Poplawski
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 14:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-10-29 13:39:44 EDT
Description of problem:

logwatch is reporting:

 --------------------- Init Begin ------------------------ 

 
 **Unmatched Entries**
 rc5 main process (1447) terminated with status 1
 rc5 main process (1447) terminated with status 1
 
 ---------------------- Init End ------------------------- 


This is because the last line of /etc/rc.d/rc:

[ "$do_confirm" = "yes" ] && rm -f /var/run/confirm

results in an exit code of 1.  Probably want an "exit 0" and the end of this, and possibly others, script.

Version-Release number of selected component (if applicable):
initscripts-8.84-1.x86_64
Comment 1 Bill Nottingham 2008-10-29 14:30:15 EDT
Added in git, will be in 8.85-1. Thanks!

Note You need to log in before you can comment on or make changes to this bug.