Bug 469065 - Patch to fix rebind segfault
Patch to fix rebind segfault
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nss_ldap (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nalin Dahyabhai
BaseOS QE
:
Depends On: 469061
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 14:30 EDT by Nalin Dahyabhai
Modified: 2008-10-29 16:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: 261-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 16:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2008-10-29 14:30:36 EDT
+++ This bug was initially created as a clone of Bug #469061 +++

Description of problem:
When pam_ldap is build against sasl, and openldap is new, the codepath uncovered is buggy. It tries to dereference session->info->something when info == 0.

This breaks horribly when you use binddn and first search returns referral.
The attached patch fixes the problem (verified and tested on my lovely AD forest).

--- Additional comment from i@stingr.net on 2008-10-29 14:10:07 EDT ---

Created an attachment (id=321841)
The attached patch FIXES THE PROBLEM I hate bugzilla

--- Additional comment from nalin@redhat.com on 2008-10-29 14:29:21 EDT ---

The patch looks obviously correct to me.  Not sure where we are for F10 (I'm reading final development freeze as being yesterday), so this may have to go out as an update rather than in the release proper, but I'll add it to the package.

Thanks!
Comment 1 Nalin Dahyabhai 2008-10-29 16:17:05 EDT
Oops, due to timing, for RHEL 5 I didn't pull in the updated patch from the upstream bug tracker, which didn't include the additional support for rebinding using SASL that needed to be patched here.  Marking this as, uh, closed->rawhide.

Note You need to log in before you can comment on or make changes to this bug.