Bug 469084 - k3b and growisofs can no longer burn ISO images to DVDs though CDs work fine
k3b and growisofs can no longer burn ISO images to DVDs though CDs work fine
Status: CLOSED DUPLICATE of bug 455876
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: k3b (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Roman Rakus
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 15:59 EDT by Charlotte Richardson
Modified: 2014-01-12 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 07:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-10-29 15:59:33 EDT
Description of problem:
This worked in RHEL4U6. Neither k3b nor growisofs used independently can successfully burn valid DVDs from ISO images under RHEL4U7 although CDs work fine (even when burning the same ISO image).

If you select "verify written data" in k3b when burning a DVD, when it finishes burning and checking the DVD, it will report "The written data differs".

K3b uses the following growisofs command:
/usr/bin/growisofs -Z /dev/hda=<ISO file> -use-the-force-luke=notray
-use-the-force-luke=tty -speed=4

The version of k3b in RHEL5.2 uses this command, so I tried it also:
/usr/bin/growisofs -Z <ISO file> -use-the-force-luke=notray 
-use-the-force-luke=tty -dvd-compat -speed=4
-use-the-force-luke=bufsize=32m

Both growisofs commands produced the same result as using k3b: once the image has been burned, if you do cmp <ISO file> /dev/hda, you get
cmp: EOF on <ISO file>

Burning CDs works fine (even if you burn the same ISO image).


Version-Release number of selected component (if applicable):
k3b and growisofs in RHEL4U7.


How reproducible:
Always


Steps to Reproduce:
1. Attempt to burn an ISO image to a DVD using either k3b or growisofs.
2. cmp the original file with the media you just burned.

  
Actual results:
The media you burned is not valid. It appears to be longer than the original ISO file.


Expected results:
Should work (used to work). The burned image should be identical to the original file.

Additional info:
This is unlikely to matter... the DVD burner I am using is a Matshita DVD-RAM UJ870PC IDE DVD burner, and it is connected via a PIIX.
Comment 1 Roman Rakus 2008-10-30 07:05:38 EDT

*** This bug has been marked as a duplicate of bug 455876 ***

Note You need to log in before you can comment on or make changes to this bug.