Bug 469100 - Poor performance of i965 on fedora 10
Poor performance of i965 on fedora 10
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 17:21 EDT by Krzysztof "Uosiu" Hajdamowicz
Modified: 2009-10-22 09:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.0.log without compiz (260.32 KB, text/plain)
2008-10-29 17:21 EDT, Krzysztof "Uosiu" Hajdamowicz
no flags Details

  None (edit)
Description Krzysztof "Uosiu" Hajdamowicz 2008-10-29 17:21:51 EDT
Created attachment 321869 [details]
my xorg.0.log without compiz

Description of problem:
my video chipset
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
had ~700fps in glxgears in f9 with excellent performance in games: xmoto, openarena, alienarena and compiz (compiz caused memory leak, but it is not a topic of this bug)- everything made hardware-way.

In Fedora 10 i had drivers xorg-x11-drv-i810 in versions 2.4.2 and 2.5.0 and both of them makes 200fps in glxgears with 100% of CPU0 usage and ~4fps in xmoto (sic! it is 2d platform game!) and with this result I didn't even started to test in quake2/3 based games.

Before release of 2.5.0 intel x11 driver I've been using 2.3.2 version from f9, but it now doesn't working.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install f10- if You want- update. It doesn't change anything
2. Make sure that compiz* is disabled - for better performance
3. Try to play game using any kind of graphics acceleration
  
Actual results:
~70-200fps in glxgears with 100% CPU usage
~4fps in xmoto
~0.25fps in ppracer

Expected results:
~700fps in glxgears with <10% cpu usage
~25 fps in ppracer
~100fps in xmoto if possible

Additional info:
22:17 [ uosiu @ samhain ] /home/uosiu > glxgears
397 frames in 5.0 seconds = 79.172 FPS
403 frames in 5.0 seconds = 80.499 FPS
409 frames in 5.0 seconds = 81.769 FPS
21:50 [ root @ samhain ] /root ROOTMODE> xdriinfo
Screen 0: i965

My hardware configuration: http://blog.uosiu.info/2008/04/11/linux-on-laptopscom-lenovo-r61i-and-fedora8/
Comment 1 Matěj Cepl 2008-10-29 19:13:42 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-10-29 19:23:45 EDT
sorry, overlooked that log has been already attached. DOn't bother with the rest.
Comment 3 Krzysztof "Uosiu" Hajdamowicz 2008-11-07 17:15:51 EST
hmmm.... suprise!
23:13 [ uosiu @ samhain ] /home/uosiu > glxgears
4985 frames in 5.0 seconds = 996.949 FPS
5282 frames in 5.0 seconds = 1056.380 FPS
4923 frames in 5.0 seconds = 984.413 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 47920 requests (47365 known processed) with 0 events remaining.
23:14 [ uosiu @ samhain ] /home/uosiu > rpm -q xorg-x11-drv-i810
xorg-x11-drv-i810-2.5.0-1.fc10.x86_64
Comment 4 Ben Gamari 2008-11-07 19:50:04 EST
Is this to say that the issue is now fixed?
Comment 5 Krzysztof "Uosiu" Hajdamowicz 2008-11-08 02:48:05 EST
In my opinion- yes, but performance of intel under linux is still lower than in windows (laggy ppracer VS nfs most wanted@1024x768@medium)
Comment 6 Bug Zapper 2008-11-25 23:28:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Pedro Lamarão 2008-11-27 19:50:31 EST
Is this bug the same as #444328 ?
Comment 8 Vedran Miletić 2009-09-06 03:49:48 EDT
Comment #7: yes.

*** This bug has been marked as a duplicate of bug 444328 ***

Note You need to log in before you can comment on or make changes to this bug.