Bug 469141 - KDM clock label overflows the login box
KDM clock label overflows the login box
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: solar-kde-theme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 00:31 EDT by Kevin Kofler
Modified: 2008-11-04 12:25 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.1.15-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 12:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2008-10-30 00:31:37 EDT
Description of problem:
The date/time label runs over the right boundary of the login window, at least at 1280x800, my attempts so far to fix it have been unsuccessful. I tried changing:
<pos anchor="w" y="32" x="80%"/>
to any of:
<pos anchor="e" y="32"/>
<pos y="32"/>
<pos anchor="e" y="32" x="100%"/>
<pos anchor="e" y="32" x="0"/>
<pos anchor="e" y="32" x="0%"/>
none of which had the intended effect.

Version-Release number of selected component (if applicable):
solar-kde-theme-0.1.10-3.fc10

How reproducible:
Always

Steps to Reproduce:
1. Try to use KDM on a 1280x800 screen.
  
Actual results:
Clock overflows to the right.

Expected results:
Clock appears fully within the box.

Additional info:
See also bug 469048, but this is not the same bug.
Comment 1 Jaroslav Reznik 2008-10-30 11:50:01 EDT
I can confirm it on my 1280x800 laptop. It seems OK with max-width set for label.
Comment 2 Kevin Kofler 2008-11-02 14:01:40 EST
solar-kde-theme-0.1.12-1.fc10 tagged f10-final.
Comment 3 Kevin Kofler 2008-11-02 14:47:55 EST
Uh, now it's overflowing again, I have no idea what changed, maybe the contents of the date string ("November" rather than "October" maybe?), but in any case I see it overflowing again now (with 0.1.12-1.fc10). :-(

I'm afraid this needs more work.
Comment 4 Kevin Kofler 2008-11-02 14:51:26 EST
As unlikely as it can be, I also upgraded kdebase-workspace to a build with the KDM session-button patch, so there's some remote possibility that that could also be causing it (though I don't see how, as it only touches a popup, so it shouldn't be affecting the layout at all).
Comment 5 Jaroslav Reznik 2008-11-03 06:03:04 EST
I'm trying similar trick as for welcome label - box with centered clock label and constrained to match login box. So it won't overflow but truncate it.
Comment 6 Ngo Than 2008-11-04 11:11:47 EST
Kevin. could you please try 0.1.15-1?
Comment 7 Kevin Kofler 2008-11-04 11:37:36 EST
Looks fixed, hopefully this time is the good one. :-)
Comment 8 Rex Dieter 2008-11-04 12:25:21 EST
latest build tagged, closing.

Note You need to log in before you can comment on or make changes to this bug.